none
Elasticsearch Container increase vm.max_map_count RRS feed

  • Question

  • Hi,

    i want to setup elasticsearch as container instance. Unfortunately the launch of the container stops with en error:

    max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]

    How can i increase this property or launch elasticsearch as container instance successfully? I have no problem with this property on my local machine.

    Thx a lot for your help.

    Wednesday, November 14, 2018 3:26 PM

All replies

  • Hi uucly,

    This issue is happening because the containers max map count is less that what Elasticsearch is expecting.

    Elasticsearch runs bootstrap checks for production environment.  max map count check is one of them.

    You can solve this issue by setting the max map count explicitly.

    Take a look at this Elasticsearch doc which suggests to set the minimum virtual memory setting.  

    I think the default value is 65530. In virtual machines we can easily change this value easliy. In container instances, we don't have access to the underlying VM. I will check and update you.

    Friday, November 16, 2018 7:02 AM
    Moderator
  • HI Uucly,

    I checked with the Product team. Increasing the max map count is not possible for Azure container instances. We can use AKS where we have access to the underlying nodes.

    Monday, December 10, 2018 4:48 AM
    Moderator
  • I solved it using the following image from Docker Hub: 

    elasticsearch:5.6.14-alpine


    • Edited by Marco Mansi Wednesday, December 19, 2018 10:21 AM
    Wednesday, December 19, 2018 10:20 AM