none
Deploy ASDK 1908 RRS feed

  • Question

  • hi 
    I tried to install "ASDK 1908" 
    I Checked Sevrer befor mounting it to vhdx and the "asdk-prechecker" answer was correct (successfully)
    But after booting with "VHDX" I checked it again and got the error below.(Image No1)
    I tried to install "ASDK" no matter the error but got the following error.
    I did the installation from "ADSF" method
    Why do I get errors from my "storage" and "cluster"
    Another question
    I need to have four interfaces or one is enough ?
    please guide me
    Faithfully yours,
    Mehrdad Gh 

    ------------


    Server detail:
    Dell R730 
    5 lff 2T HDD raid0
    all HDD is online on list disk 
    PERC H730 Mini (Embedded) raid controller 
    192GB RAM 
    20 CORE CPU 
    1 NETWORK Interface with static private ip
    "physically" installed win server 2016 (BareMetal )

    ---------------

    No3
    • Edited by MehrdadHGh Friday, September 20, 2019 6:07 PM
    Friday, September 20, 2019 1:20 PM

Answers

All replies

  • 1) the ASDK Prechecker is supposed to be run before booting into the .VHDX. I would ignore errors that you get while booted into the .VHDX. 

    2)Unfortunately the installer script does not give a good error for the failure reason on Storage, but it is failing fairly early on while trying to create the storage. 

    Make sure that your disks meet the requirements Here. You can also run this script to remove all existing partitions on the drives and make sure that they are ready for the ASDK installation. This will remove all existing data from the drives, so make sure that there is no needed data on the drives. This script is best run from the Base OS, and not from the .VHDX. You might need to re-download the .VHDX once your storage has been verified. 

    $d = Get-Disk |? IsBoot -ne $true |? IsSystem -ne $true |?
    PartitionStyle -ne RAW
    
        if ($d.Count) {
    
            $d |% { $_ |
    Set-Disk -isoffline:$false }
    
            $d |% { $_ |
    Set-Disk -isreadonly:$false }
    
            Clear-Disk
    -Number $d.Number -RemoveData -RemoveOEM -Confirm:$false
    
            $d |% { $_ |
    Set-Disk -isreadonly:$true }
    
            $d |% { $_ |
    Set-Disk -isoffline:$true }
    
        }

    After this has run and the partitions have been cleared, can you run the script below and paste the output here? This will verify that your disks are in the proper state and ready for installation:

    $availableDisks = Get-Disk |? { $_.IsBoot -ne $true -and $_.IsSystem -ne $true }
    
    foreach ($disk in $availableDisks)
    
    {
    
       
    $disk | fl
    
       
    $disk | Get-Partition
    
    } 


    3) The requirements for NICs are listed Here. Only 1 physical NIC is required before the install, and multiple Virtual NICs will be created by the installer script. 

    Friday, September 20, 2019 10:03 PM
    Moderator
  • My understanding is that the discs should be offline
    I offlineed them and checked up again
    I was able to install "ASDK" without a problem
    Thank you for helping me.

    Faithfully yours

    Mehrdad Gh 



    Sunday, September 22, 2019 7:25 AM
  • Thank you for providing the solution. I will mark your response as answered to help other community engineers. 

    Regards, 

    Msrini

    Sunday, September 22, 2019 6:32 PM
    Moderator