none
Azure Monitor alert action does not send email RRS feed

  • Question

  • Hello everyone,

    I am having an issue with Azure Monitor email alerts.

    I can see that Alert is triggered and in History tab I can see that Action group was executed. However, I did not receive any email. 


    There is only one action - Email Azure Resource Manager Role - Monitoring Reader

    And I can confirm that I belong to that role 

    But I did not received an email. 

    If I go to https://account.activedirectory.windowsazure.com/r/#/profile

    I can see that email field is empty and I dont know how to fill it in. 

    Can it be the reason? 

    Appreciate your help.

    BR,

    Ruslan

    Monday, September 30, 2019 10:11 AM

Answers

  • Hello Irriss,

    Sorry to hear that you are still having the same problem. 

    As requested earlier, Do you mind sending an email to AzCommunity@Microsoft.com  to investigate this issue further. 

    Subject : ATTN:Monika 

    Please provide the link to this thread your subscription ID as well. 

    And to get notified when there is an update on the thread, you can click on 'Alert Me" button on top of the page, 

    I hope this information helps. Will look forward for your email. 

    Thanks in Advance. 



    Thursday, November 7, 2019 2:39 PM
    Owner

All replies

  • Hello Ruslan, 

    Can you please make sure email address in Azure Active Directory blade in portal is configured? 

    To get email Notifications, possible options are: 

    1) Configuring email address to the Azure AD account

    2) Selecting Email Action type in Monitor Alerts. 

    Please go through the below steps to setup email for receiving Notifications. 

    1) Configuring email address in Azure AD account. 

       - Login to Azure portal

       - Click on Azure Active Directory -> Users -> In Searchbox -type your name it will filter with your   account info. 

       - Once you have your name popped up, click on it and you should be able to see the 'EDIT' button where you Edit your profile information and update the email address. 

    Try this option to see if it works for you. Please see the below screenshot for more info. 

     

    (OR)

     

    2) Setting up Email ActionType in Azure Monitor Blade. 

       - Login to Azure Portal.

       - Navigate to Azure Monitor Blade -> Alerts -> Manage Actions -> Type your resource group name in the search bar.

       - Once you see Action, click on it and you should be able to see the NotificationDetails Blade.

       - Once the blade opens, you can select the action type 'Email/SMS/Push/Voice' from the dropdown as           shown below, after selecting it, click on EDIT and enter your email address.


    This should trigger sending email notifications. Please see the below screenshot for more info. 

    I hope this information helps. Please let me know if this solutions works for you.

    Thanks.






    Thursday, October 3, 2019 9:31 PM
    Owner
  • Thanks Monika!

    Option (2) - Setting up Email ActionType in Azure Monitor Blade - works well. But I would like to figure out why notifications are not sent to Monitoring Reader role. 

    Regarding option (1) - I did the steps and this is what I see:

    As you can see there is no field for email address. However field "username" contains my valid email address. 

    However, if I go to https://account.activedirectory.windowsazure.com/r/#/profile

    I can see that email field is empty and I dont know how to fill it in. 

    Not sure what it means and how it is relevant.

    Friday, October 4, 2019 2:58 AM
  • Hello Ruslan, 

    I am glad to hear that one of the options worked for you.

    However, I am trying to figure out why the email ID field is empty and working with my internal team here on how we can update the profile info in Windows AD account. I will keep you posted once I have any further updates on this.

    Meanwhile, can you let me know what you see in Authentication methods Blade in the portal. 

    • Login to Azure Portal
    • Access Users - Click on the user you would like to Edit - Authentication Methods. See the below screenshot for more info. 

    Feel free to let me know if you have any further questions. 

    Tuesday, October 8, 2019 9:07 PM
    Owner
  • Hello Ruslan, 

     

    I did hear back from our internal product team.

     

    Basically, to ensure that you are receiving email notification corresponding to these roles below main conditions need to be met.

    • Role needs to be assigned at the subscription scope, and not at any of the child scopes (like resource/resource group/action group, etc.).
    • Type of the entity assigned to the role has to be "User", as we do not resolve and send emails to any other types like "Group".

    Also, It could take up to 24 hours for newly added/updated role assignments to be reflected and for email delivery to begin for those users, as per our caching policy for the ARM roles.

     

    Would request you to validate the above conditions are met and see if the email alerts are being sent or not. If you still continue to see the issue would request you to send an email to AzCommunity@microsoft.com  with your Subscription details, action group ID and a link to this thread so we can verify and direct the request accordingly for further troubleshooting.

     

    Hope this information helps. Please revert back if you have any queries.


    Monday, October 21, 2019 2:49 PM
    Owner
  • Hi Monica, sorry for the late reply. (i dont receive notifications for these posts here as well, however it is a different account)

    I checked authentication methods. This is what it shows

    Authentication methods are the ways your users sign into Azure AD. Here, you can set the ​phone numbers and email addresses that users use to perform multi-factor authentication​ and self-service password reset, and reset a user’s password.
    Authentication contact info
    Alternate email
    (my correct email here)
    Manage your other authentication contact information in your Access Panel Profile


    • Edited by irriss Thursday, November 7, 2019 2:28 PM
    Thursday, November 7, 2019 2:28 PM
  • I can confirm that it is at the level of a subscription and the role is assigned to my user, not a group.

    BTW there are more people having the same issue https://github.com/MicrosoftDocs/azure-docs/issues/32730

    Thursday, November 7, 2019 2:31 PM
  • Hello Irriss,

    Sorry to hear that you are still having the same problem. 

    As requested earlier, Do you mind sending an email to AzCommunity@Microsoft.com  to investigate this issue further. 

    Subject : ATTN:Monika 

    Please provide the link to this thread your subscription ID as well. 

    And to get notified when there is an update on the thread, you can click on 'Alert Me" button on top of the page, 

    I hope this information helps. Will look forward for your email. 

    Thanks in Advance. 



    Thursday, November 7, 2019 2:39 PM
    Owner
  • Hi Monika,

    I received email notification for your reply!

    Will do as you request.

    Thanks for your help.

    Thursday, November 7, 2019 2:43 PM