none
Timeout in Web service

    Question

  • Hi,

    I have an azure ML prcess which predicts then end of a device's lifetime, and I want to set up this experiment. It works, but if I test the Web service it runs out of time. Do you know how I can solve this problem?

    For this prediction I read my table, select the entities from that device and process them, but it's not abnormal and in training it works within a minute or three.

    The error message I get is: "Unable to finish 'BatteryDeathTimer [Predictive Exp.]' test. The operation could not be completed within the permitted time."

    Thanks!

    Filip



    • Edited by Filip VR Wednesday, January 27, 2016 4:25 PM
    Wednesday, January 27, 2016 4:21 PM

Answers

All replies

  • Hi Filip,

    I suspect you are invoking the web service using RRS (Request-Response Service) mode which is for low latency and has a timeout around 90 seconds. It is hence recommended that you use BES (Batch Execution Service) mode of invoking your web service.

    https://azure.microsoft.com/en-us/documentation/articles/machine-learning-consume-web-services/

    Regards,
    Jaya.

    • Marked as answer by Filip VR Wednesday, January 27, 2016 9:36 PM
    Wednesday, January 27, 2016 4:44 PM
  • I actually used the 'test' button, but I think this will work, thanks!

    Wednesday, January 27, 2016 9:37 PM
  • Hi Filip,

    Yes, the 'Test' button tests the RRS (Request-Response Service). However since your web service takes longer time, you would need to use BES (Batch Execution Service).  

    Regards,
    Jaya.

    Wednesday, January 27, 2016 10:16 PM
  • Hi Jaya,

     I use BES for invoking web services but I still get timeout when I run the web service via console app using c#. I changed the  time out property to 5 minutes and it avoided the problem little bit. But sometime I still have timeout problem and it will restart the process after deleting the jobId.

    Is there any specific reason for timeout?

    When I have >100 requests for BES how will this react ?

    • Edited by MuthuKM Tuesday, October 24, 2017 2:28 PM
    Tuesday, October 24, 2017 2:25 PM
  • hm, that is not ok at all 
    Tuesday, October 24, 2017 2:52 PM
  • <g class="gr_ gr_300 gr-alert gr_spell gr_inline_cards gr_disable_anim_appear ContextualSpelling ins-del" data-gr-id="300" id="300">HI</g> Jaya,

    I encountered the same problem as described above: Service Time-out. 

    Although it takes some time, my experiment works perfectly well in Machine Learning Studio.

    When I deploy the service and try to test the service using the request-response mechanism in the portal. Unfortunately, this is where I get a time-out error.

    I would like to try and test my service using the Batch Execution Service.

    However, I pass one parameter to the web service when using the request-response style. When I look at the Batch Execution Service, I see that it is not possible to just enter the value of the parameter. I have to upload a specific file.

    How do I have to package my parameter up in a file to test the service using the Batch Execution Service?

    Could you give some guidance?

    Many Thanks Philip

    Tuesday, January 8, 2019 6:29 PM