AAD Connect does not synchronize hash password with Linux server with Samba 4 RRS feed

  • Question

  • Hello guys. We are experiencing problems which we have the following scenario: We have a Linux server with Samba 4 configured as Active Directory, where we need to synchronize users to the Microsoft Office 365 AD. We are trying to use the AAD Connect tool, however, the software can synchronize the objects with no problems, but the password hash is not being synchronizing. We configure AD Connect to synchronize only a single OU (Organization Unit) of our local AD, that have only 2 user objects. We have already activated the AD Connect debugging log (miiserver.exe.config file) to verify what is happening, but analyzing it  seems that AAD Connect is constantly restarting reading all objects from Local AD, and does not synchronize the password , even configured to synchronize only a single OU. If we force a synchronization with troubleshooting option of AAD Connect with an specific user, so the password is synchonized with no problems too.

    Does anyone have any idea what is happening?


    Friday, May 4, 2018 7:20 PM

All replies

  • Hello,

    Please check the troubleshooting guidance provided in this document - No passwords are synchronized: troubleshoot by using the troubleshooting task.

    If your issue is still not resolved, you may need to open Azure Support ticket so that Identity Support Engineer could further assist you in this regard. Let me know if you have any support plan restrictions in opening Azure Support ticket.

    • Proposed as answer by MohitGarg_MSFT Thursday, May 10, 2018 10:27 PM
    Friday, May 4, 2018 10:20 PM
  • Yes. I’ll do this. Thank You.
    • Proposed as answer by the_horhe Monday, March 4, 2019 1:32 PM
    • Unproposed as answer by the_horhe Monday, March 4, 2019 1:32 PM
    Friday, May 4, 2018 11:08 PM
  • I know this is a relative old topic but did you get this resolved?

    Do you have a working AAD Connect with a samba4 AD?

    Thank you for a quick recap on the issue!

    Monday, March 4, 2019 1:33 PM