none
Trouble Starting Azure Stack - Start-AzureStack RRS feed

  • Question

  • Hello, I have Tried to start my Azure Stack Deployment on Host Machine and though I have done this several times successfully,  I now come into an error as below:

    Windows PowerShell
    Copyright (C) 2016 Microsoft Corporation. All rights reserved.
    
    PS C:\Windows\system32> Enter-PSSession -ComputerName AzS-ERCS01 -ConfigurationName PrivilegedEndpoint
    WARNING: The names of some imported commands from the module 'ECEClient' include unapproved verbs that might make them
    less discoverable. To find the commands with unapproved verbs, run the Import-Module command again with the Verbose
    parameter. For a list of approved verbs, type Get-Verb.
    [AzS-ERCS01]: PS>Start-AzureStack
    VERBOSE: Create Client for execution of action plan
    VERBOSE: Start action plan
    VERBOSE: Action plan instance ID specified: d06bd49d-b54b-4935-a0e8-2420b296cc29
    VERBOSE: Error in ECEClient.
    Error:
    Exception calling "GetResult" with "0" argument(s): "Cannot invoke action plan because another action is in progress:
    bc9c270e-f539-456a-9a4f-fb20b8789d6a"
    tnc : The term 'tnc' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the
    spelling of the name, or if a path was included, verify that the path is correct and try again.
    At C:\Program Files\WindowsPowerShell\Modules\ECEClient\ECEClient.psm1:673 char:26
    +             $tcpresult = tnc -computer ASAppGateway -Port 4443
    +                          ~~~
        + CategoryInfo          : ObjectNotFound: (tnc:String) [], CommandNotFoundException
        + FullyQualifiedErrorId : CommandNotFoundException

    I've tried running "Test-AzureStack" However it stays stuck on "starting AzsInfraperformance".How can i further resolve/troubleshoot this? I have no changed any files or paths. I simply just restarted the host machine.

    Thanks


    • Edited by Nick Ninio Thursday, September 12, 2019 9:39 PM clarity
    Thursday, September 12, 2019 9:34 PM

All replies

  • If needed, you can restart the ASDK host computer to see if another Start-AzureStack succeeds.

    What version of the ASDK are you using?

    Friday, September 13, 2019 12:48 AM
    Moderator
  • @TravisCragg_MSFT

    I have tried restarting my host computer and the issue unfortunately persists. Do you know how I can resolve this? I don't have context around what other action instance the message is mentioning about. I also cannot find ECEClient.psm1 within the path. I'm not sure what 'tnc' not found means either.

    Thanks!

    Friday, September 13, 2019 3:14 AM
  • Looks to be Version 1904. Thanks.
    Friday, September 13, 2019 3:39 PM
  • I am going to follow up to see if there is anything else that we can do, but in the past when this error has occurred to me, I have had to reinstall the ASDK. I believe it happened to me on 1904 as well. 

    Because there have been several versions between yours and the current version, it will likely be the best option to install the most recent version. 

    Friday, September 13, 2019 9:59 PM
    Moderator