Method not found: SqlServerCe.SqlCeChangeTracking.CleanupMetadata RRS feed

  • Question

  • Hi

    I'm trying to do a bidirectional sync b/t a sqlce 3.5 database with a sql server 2005 database, and following the example at: http://msdn2.microsoft.com/en-us/library/bb726007(SQL.100).aspx

    when I issue the Synchronized() command, I recieved the following error:

    System.MissingMethodException: Method not found: 'Void System.Data.SqlServerCe.SqlCeChangeTracking.CleanupMetadata(System.String, Int32, Int64, Int64)'.
    at Microsoft.Synchronization.Data.SqlServerCe.SqlCeClientSyncProvider.SetTableSentAnchor(String tableName, SyncAnchor anchor)
    at Microsoft.Synchronization.Data.Client.InternalSyncAgent.UploadChanges(SyncGroupMetadata groupMetadata)
    at Microsoft.Synchronization.Data.Client.InternalSyncAgent.Synchronize()
    at Microsoft.Synchronization.SyncAgent.TryDoDataSync(SyncStatistics& statistics)
    at Microsoft.Synchronization.SyncAgent.Synchronize()
    at CustomerSyncTest.Form1.button2_Click(Object sender, EventArgs e) in C:\Documents and Settings\wliao\My Documents\Visual Studio 2005\Projects\CustomerSyncTest\CustomerSyncTest\Form1.cs:line 76

    I didn't find this mentioned anywhere, help?

    • Moved by Max Wang_1983 Tuesday, April 19, 2011 11:04 PM Forum consolidation (From:SyncFx - Microsoft Sync Framework Database Providers [ReadOnly])
    Wednesday, January 30, 2008 5:20 PM

All replies

  • never mind. i figured it out.
    Friday, February 1, 2008 4:14 PM
  • I'm getting the same error. How did you figure it out?
    Monday, March 3, 2008 1:51 PM
  • It's been a while, I went back to the code (which changes a lot since then) and tried to recall what I did but I don't remember exactly, all I vaguely remember was that it was something extremely simple, possibly a typo or an incorrect table name, so don't over think it. Sorry can't be of much help.
    Monday, March 3, 2008 4:54 PM
  • I had this error and found that I was not referencing program files \Program Files\Microsoft SQL Server Compact Edition\v3.5\Devices\System.Data.SqlServerCe.dll
    It was pointing at my debug folder.
    I deleted and readded the  reference and it fixed the error.
    • Proposed as answer by Kyle Leckie Thursday, December 24, 2009 2:03 AM
    Wednesday, December 23, 2009 1:01 AM