locked
Register a new application using the Azure portal - unable to obtain API Permissions RRS feed

  • Question

  • I am trying to add the following API permission to the newly created app:

    Add Permission > Microsoft Graph > Delegated permissions > Files.ReadWrite.AppFolder

    I get the following message each time when I try to add the above permission:

    Experiencing authentication issues
    The portal is having issues getting an authentication token. The experience rendered may be degraded.

    I have been trying to add that permission for the whole week now.

    What's wrong with the Azure Portal ??

    Am I doing something wrong ?

    Application ID: 7a1ac741-5d76-4691-a7d7-56f9f78be3e8

    Wednesday, February 19, 2020 11:34 PM

Answers

  • Thank you very much for your reply. I have managed to sort out the reported issue.

    It appears that I was not properly registered as a user at Azure.

    Once this was sorted, I could change the App Permissions and get it working.

    Once again, thank you for your support.

    Sunday, February 23, 2020 7:55 AM

All replies

  • We're migrating from MSDN to Microsoft Q&A as our new forums and Azure AD has already made the move!  To ease your transition experience, we have created a forum thread on Q&A where one of our specialized engineers in the subject or the Azure community members can provide the best possible answer to your scenario or question. In future, you can ask and look for the discussion for Azure AD App registration related questions here.

    We are actively working to onboard remaining Azure services on Microsoft Q&A. We will make a public announcement once complete. Want to Learn more about new platform: Microsoft Q&A Getting Started
    Thursday, February 20, 2020 6:18 AM
    Owner
  • MarioFB1, Looks like some issues in the backend. We can look into that. Can you provide some more details about the issue like:

    1. What type of app is this? (Is this an app service which you are trying to register in AAD with that permission?)

    2. If you try another App Registration, and try to add that same permission or any other delegated permission, do you still see that same error?

    3. Also, which data center are you connected to? You can find that info by checking the AAD Properties blade [please refer to the screenshot] 3211-img1.png

    I would like to check the tenant, hence please do drop us an email at azcommunity'at'micorsoft'dot'com with the following details:

    1. Tenant Name/Id

    2. App Name/Id

    3. Username with which you are trying to add the permissions.

    Friday, February 21, 2020 4:46 AM
  • Thank you very much for your reply. I have managed to sort out the reported issue.

    It appears that I was not properly registered as a user at Azure.

    Once this was sorted, I could change the App Permissions and get it working.

    Once again, thank you for your support.

    Sunday, February 23, 2020 7:55 AM
  • Hi Mario, I am facing a similar issue as you did. Can you please explain what do you mean by you were not properly registered as a user at Azure.
    Monday, March 2, 2020 8:06 AM
  • I had to create a new Azure client account:

    https://azure.microsoft.com/en-us/free/search/?&ef_id=EAIaIQobChMIqZ2F87b75wIVCLaWCh05nwcuEAAYASAAEgIFuPD_BwE:G:s&OCID=AID2000101_SEM_PUxRlGpq&MarinID=PUxRlGpq_332091364069_create%20azure%20account_e_c__63859601503_kwd-310735070824&lnkd=Google_Azure_Brand&dclid=CIHD-vW2--cCFQR5jwodzVIDCA

    I had to provide my credit card to create it (the account is free to sign in).

    Once I had the account, I was able to mange the OneDrive app permissions.

    Please let me know if you have succeeded.

     
    Monday, March 2, 2020 9:07 AM
  • I changed the location details. Changed address to US and it worked for me. Thanks for the help.
    Thursday, March 5, 2020 9:55 PM