none
ODBC Connection Failed RRS feed

  • Question

  • Cannot create an ODBC connection to local host. I can create a connection successfully in Microsoft SQL Server Management Studio 18. But when I try adding a new ODBC connection using ODBC Data Source Administrator, I cant. In ODBC Data source administrator I tried to connect to SQL Server. Then look for the available server. But it is only showing the network servers and not the local host. So I just go to SSMS and then just copy the server name which is (LocalDB)\.... and then copy it in the server position in ODBC Data source adminsitrator, but then an error is showing. 

    Connection failed:
    SQLState: '01000'
    SQL Server Error 53
    [Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionOpen
    (Connect()).
    Connection failed:
    SQLState: '08001'
    SQL Server Error 53
    [Microsoft][ODBC SQL Server Driver][DBNETLIB]SQL Server does not exist or access denied.

    I went online and checked for it. Answer was to make some changes in SQL Configuration Manager which is enable the Named Pipes. But there is no SQL configuration manager or .msc file. So what is the problem. Kindly help me. Thank You. 

    Friday, May 29, 2020 9:46 AM

All replies

  • then just copy the server name which is (LocalDB)\....  

    LocalDB is not really a server system as e.g. SQL Express, it starts only on demand and I am not sure if ODBC supports this.

    Start the LocalDB instance manually, see SqlLocalDB Utility => Start


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Friday, May 29, 2020 9:58 AM
  • There is already a local instance. That is (LocalDB)\MSSQLLocalDB. That is what I connect to in Microsoft Visual Studio 18. But I cannot create a ODBC conncection for that. 
    Friday, May 29, 2020 11:04 AM
  • Thank You. I got it fixed. The mistake was I selected the wrong driver. I selected sql server driver when actually the correct one was ODBC driver 17 for SQL Server. 
    • Proposed as answer by AV111 Friday, May 29, 2020 2:30 PM
    Friday, May 29, 2020 11:17 AM
  • HI Govind,

    Glad to hear you have solved the issue.

    Best regards,

    Melissa

    Monday, June 1, 2020 1:56 AM