locked
[Wordpress] WebApps time-to-first-byte is extremely slow RRS feed

  • Question

  • Domain Name: https://www.frogmd.com

    I am on a Standard S2 plan.

    I am currently running a Webapp: Wordpress with a SQL db. The time-to-first-byte is extremely slow (varying, but at time up to 20 seconds).

    My developers can't seem to figure out why this is happening. I am not a developer or a SQL admin, but here are the things that I know about our current system:

    Front-end: mostly PHP. basic js and jquery. 

    Back-end: SQL db with C# datafactory and a blob storage for documents

    I read that this slowness is very common for Azure / Wordpress setups. Multiple forums and online communities seems to be a have fixed this issue by implementing a variation of the following tactics:

    • Upgrading PHP from v5.6 to v7.1
    • Edit .users.ini file - add text: output_buffering = off;
    • Edit web.config and add following code:

    <configuration>      
         <system.webServer>
             <handlers>
                <add name="PHP-FastCGI"
                    path="*.php"
                    verb="GET,HEAD,POST"
                    modules="FastCgiModule"
                    scriptProcessor="D:\Program Files (x86)\PHP\v5.4\php-cgi.exe"
                    resourceType="Either"
                    requireAccess="Script" 
                    responseBufferLimit="0" />
             </handlers>
          </system.webServer>
    </configuration>

    All 3 of these crashed the site completely. I attempted each modification one-by-one.

    This is extremely frustrating because the site is much too slow for a practical application in the real world. Our clients are getting tired of waiting for the page to load and we're very close to having to move our hosting to a different platform. Please help.



    Friday, December 8, 2017 2:02 PM

All replies

  • If ‘Always On’ feature/setting isn’t enabled, I suggest you enable the setting and see if that makes any difference. By default, web apps are unloaded if they are idle for some period of time. This lets the system conserve resources. In Basic or Standard mode, you can enable Always On to keep the app loaded all the time.

     

    Consider implementing the quick and easy steps mentioned in the document How to speed up your WordPress site on Azure App Service to speed up your application and then check to see if that makes any difference.

     

    You have posted the question on Azure Virtual Machines forums, however from the issue description it appears that you are hosting your website on Azure WebApps, do confirm. We have moved your thread to right forum for appropriate audience.

    ---------------------------------------------------------------------------------------------------

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.


    Friday, December 8, 2017 6:53 PM
    Owner