none
azsphere device prep-sideload --enablertcoredebugging Not working in Azure sphere sdk 19.10 RRS feed

  • Question

  • Hi, 

    I am new to this platform. I am exploring Avnet's MT3620 Azure sphere dev kit for my use. 

    I was trying to "Build a real-timecapableapplication with Visual Studio". I was following the instructions quite carefully up until I hit a road block. 

    Despite updating the sdk and migrating the tenants the command line does not recognize prep-sideload

    >>azsphere device prep-sideload --enablertcoredebugging

    What should I do?

    Thanks in advance

    Aritra

    Friday, November 8, 2019 4:31 AM

All replies

  • Hi Aritra,

    Sorry for the inconvenience caused.  We will try from our end and update you as earliest.

    • Proposed as answer by Jeremy_K Friday, November 8, 2019 12:37 PM
    • Unproposed as answer by Jeremy_K Friday, November 8, 2019 12:37 PM
    Friday, November 8, 2019 12:00 PM
    Moderator
  • The new command for Azure Sphere SDK 19.10 is
    azsphere device enable-development --enablertcoredebugging
    
    • Proposed as answer by Jeremy_K Friday, November 8, 2019 12:37 PM
    • Edited by Jeremy_K Friday, November 8, 2019 12:37 PM
    Friday, November 8, 2019 12:37 PM
  • Dear friend,

    Just as Jeremy pointed out here, the azsphere command-line interface (CLI) incorporates numerous changes to support RBAC and the new cloud management environment in version 19.10. Please refer to this docs for more details:

    New and changed azsphere CLI commands in What's new.


    Keep Fighting

    Monday, November 11, 2019 11:53 AM
  • Hi Aritra,

    As Jeremy and Jiong mentioned, please use the latest command azsphere device enable-development --enablertcoredebugging.

    We are in the process of updating the documentation and changes will go live in the next release as earliest.

    Monday, November 18, 2019 4:39 AM
    Moderator