none
Text highlighting doesn't work properly anymore after installing custom theme RRS feed

  • Question

  • As you can see in the screenshot, the free space background color does change entirely but the background color of other text elements seems to only be tinted by a very low amount.
    I don't know what caused this and checked the whole Fonts and Colors list but couldn't find anything to change this behaviour.
    F.e. if you select some text in the Light theme you will find that the background of everything selected has the same color.

    If anyone has a clue how to change this, please let me know.

    Sorry can't post an image, maybe try it here:
    https://ibb.co/87PS1hx

    Thursday, January 23, 2020 6:34 PM

All replies

  • Hi MysticeGames,

    Welcome to MSDN forum.

    According to your description, could you please share some details about your color theme? And what's the extension you used in your visual studio?

    And you could try to modify the item background of "selected Text" in Fonts and Colors.

    Any feedback will be expected.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, January 24, 2020 3:57 AM
  • Dear Dylan,

    thank you for the answer.

    The extension I used to make the custom color theme is this one: https://marketplace.visualstudio.com/items?itemName=ms-madsk.ColorThemeDesigner#overview

    The thing is changing the background color of "Selected Text" alone doesn't change that the selected text background is not fully changing color.

    If you look at the screenshot you can see that empty space is fully changing the background color to Cyan but anything with text in it seems to only tint the background color of its text type a bit.


    Sincerely,
    Jonathan
    Friday, January 24, 2020 7:14 AM
  • Hi MysticeGames,

    Sorry for delay in reply.

    I installed it and created a light theme for my VS, but the "selected Text" could work normally.

    Could you please share the more details about configuration to help us reproduce it? or your could try to re-install this extension then re-configure this theme.

    BTW, you could also go to issue tag in github page, then report this problem to developers.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, January 27, 2020 7:42 AM
  • Dear Dylan,

    thank you very much for that, so I reproduced that and found that with a new text file it doesn't do that but only with one of the .h or .cpp of my Unreal Engine project.

    So now I wonder how this can be caused by the file or solution.
    Especially since it isnt like this with a Default theme.

    Thank you very much.

    EDIT: It seems it only does that for .h and .cpp files.

    Sincerely,
    Jonathan Schumacher
    Monday, January 27, 2020 8:45 AM
  • Hi Jonathan,

    Thank you for reply.

    Since I cannot download unreal engine on my environment, I test it in C++ Console project with cpp files and header files, and they could also work. So I'm afraid that it is caused by the conflicts between VS extensions. You could try to un-install the Unreal extension, then restart VS to check if the phenomenon still persists.

    And you could also install your theme extension into other machine, then check if it could work.

    Looking forward to your feedback.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, January 27, 2020 9:32 AM
  • Hello Dylan,

    I think for the development no extension is used at all.
    There is an Unreal Engine workload but it is for the engine itself.

    So for now I think I might just try to accustom to it.

    Thanks a lot for your help, maybe in the future someone might know the reason.

    Sincerely,
    Jonathan
    Friday, January 31, 2020 7:16 AM
  • Hi MysticeGames,

    Sorry for this inconvenience.

    If you have other issues about VS IDE in the future, please feel free to contact us. We will try our best to provide a solution for you.

    Have a nice day.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com


    Wednesday, February 12, 2020 6:48 AM