locked
<m3:MinDeviceMemory>1GB</m3:MinDeviceMemory> RRS feed

  • Question

  • There is an article on MSDN, about App memory limits for Windows Phone 8: http://msdn.microsoft.com/en-us/library/windows/apps/jj681682(v=vs.105).aspx

    It says 

    • The new equivalent of ID_REQ_MEMORY_300 is below. This entry should be added to the AppX manifest (not to the WMAppManifest).

      <Prerequisites>
        <m3:MinDeviceMemory>1GB</m3:MinDeviceMemory>
      </Prerequisites>
      

    But when I add this line to my AppX manifest, the build system gives me an error APPX3002: App manifest validation failed. File contains unrecognized XML element '/Package/Prerequisites/{http://schemas.microsoft.com/appx/2014/manifest}MinDeviceMemory'.

    What can I do to fix this error?

    Friday, August 29, 2014 5:26 PM

Answers

  • This appears to be a problem with the Visual Studio build time validation.

    To work around this you can disable build-time manifest validation by adding: <AppxValidateAppxManifest>false</AppxValidateAppxManifest> , to the first PropertyGroup in your project file.  (right-click on project and select Unload project, then right click again and choose Edit ...project.)

    The manifest file will still be validated at package creation time but that code appears to work correctly for this case.


    Eric Fleck, Windows Store and Windows Phone Developer Support. If you would like to provide feedback or suggestions for future improvements to the Windows Phone SDK please go to http://wpdev.uservoice.com/ where you can post your suggestions and/or cast your votes for existing suggestions.

    • Marked as answer by Ringoz Monday, September 1, 2014 11:23 AM
    Friday, August 29, 2014 8:27 PM

All replies

  • This appears to be a problem with the Visual Studio build time validation.

    To work around this you can disable build-time manifest validation by adding: <AppxValidateAppxManifest>false</AppxValidateAppxManifest> , to the first PropertyGroup in your project file.  (right-click on project and select Unload project, then right click again and choose Edit ...project.)

    The manifest file will still be validated at package creation time but that code appears to work correctly for this case.


    Eric Fleck, Windows Store and Windows Phone Developer Support. If you would like to provide feedback or suggestions for future improvements to the Windows Phone SDK please go to http://wpdev.uservoice.com/ where you can post your suggestions and/or cast your votes for existing suggestions.

    • Marked as answer by Ringoz Monday, September 1, 2014 11:23 AM
    Friday, August 29, 2014 8:27 PM
  • Thank you, Eric.

    Hope this will be fixed in Update 4.

    Monday, September 1, 2014 11:23 AM
  • Is this because there is a namespace prefix of "m3" used in the element but there is no "xmlns:m3" definition found at the top of the WinSto Phone 8.1 Package.appxmanifest file?

    Thanks

    Boise

    Wednesday, May 13, 2015 9:07 PM