locked
My Azure web application is not connecting to Azure DB. RRS feed

  • Question

  • Please any once can help me to connecting to azure db from azure web app as its working fine in my local machine.  

    default connection is showing like this,
    Data Source=tcp:XXXX.database.windows.net,1433;Initial Catalog=XXXX_db;User Id=XXXXX;Password=XXXXXX;

    Thanks,

    Lokesh

    Wednesday, July 8, 2015 5:10 AM

All replies

  • Hi Lokesh,

    You may have to check your Azure firewall/security settings for the database.

    Here is a detailed guide on it:
    https://azure.microsoft.com/en-us/documentation/articles/sql-database-configure-firewall-settings/

    I have copy/pasted the steps below, but the URL above also has detailed screenshots (Preview portal):

    1. Log in through the Azure preview portal, at http://portal.azure.com/.
    2. In the left banner, click BROWSE ALL. The Browse blade is displayed.
    3. Scroll and click SQL servers. The SQL servers blade is displayed. (Find your Azure SQL Database server in the portal)
    4. For convenience, click the minimize control on the earlier Browse blade.
    5. In the filter text box, start typing the name of your server. Your row is displayed.
    6. Click the row for your server. A blade for your server is displayed.
    7. On your server blade, click Settings. The Settings blade is displayed.
    8. Click Firewall. The Firewall Settings blade is displayed.
    9. Click Add Client IP. Type in a name for your new rule into the first text box.
    10. Type in the low and high IP address values for the range you want to enable. (It can be handy to have the low value end with .0 and the high with .255. Add an IP address range to allow)
    11. Click Save.

    Hope that helps! :-)

    Shahed

    Thursday, September 17, 2015 4:37 AM