none
Unable to connect Redis Server on AZURE RRS feed

  • Question

  • Hi Team

    I am trying to connect to Redis Cache Server, I have written the following line to establish the connection

           private static Lazy<ConnectionMultiplexer> lazyConnection = new Lazy<ConnectionMultiplexer>(() =>
            {
                return ConnectionMultiplexer.Connect(Utils.Constants.RedisConnection);
            });

            public static ConnectionMultiplexer Connection
            {
                get { return lazyConnection.Value; }
            }

    getting the following error message 

    It was not possible to connect to the redis server(s); to create a disconnected multiplexer, disable AbortOnConnectFail. SocketFailure on PING

    I have set SSL false but no luck!! no proxy issues. appreciate your thought on the same

    regards

    Kalyan

    www.techbubbles.com

    Wednesday, April 26, 2017 9:00 PM

All replies

  • @Azuresupport guided to change the abortConnect value to false in connection string. then following new error message was appearing

    SocketFailure on XXX.redis.cache.windows.net:6380/Subscription, origin: CheckForStaleConnection, input-buffer:0, outstanding: 4, last-read: 1s ago, last-write: 1s ago, unanswered-write: 1s ago, keep-alive: 60s, pending:0, state: ConnectedEstablishing, last-heartbeat:never, last-mbeat: -1s ago, global: 1s ago, mgr:RecordConnectionFailed_ReportFailure, err: never

    just FYI - I am using Basic price tier cache

    regards

    Kalyan

    Thursday, April 27, 2017 2:05 PM
  • The error "SocketFailure" occurs when an existing connection to Redis server breaks. A connection can break due to various reasons, like a server update, a failover from Master to Slave, a network blip, a hardware failure, a server update etc. But in each of these cases, the ConnectionMultiplexer should reconnect immediately.

    Are you ever able to connect to Redis? Once you get this error, how long does it last? What is your ConnectionTimeout on the ConnectionMultiplexer? Have you changed any defaults? Are you connection from within the same Azure Region? Were you scaling your client application? If you are using Azure websites, do you have "Always On" set? By default, web apps are unloaded if they are idle for some period of time. More information is here: https://docs.microsoft.com/en-us/azure/app-service-web/web-sites-configure

    I notice that your cache is a Basic Tier cache. Please note that a Basic Tier cache is recommended only for dev / test purposes without an SLA as it is a single node solution (no replication and auto-failover) and can be unavailable if a single node goes down for any reason. You might want to consider moving up to the Standard Tier. A good starting point is a Standard C1. 

    Here are some best practices: https://gist.github.com/JonCole/925630df72be1351b21440625ff2671f#file-redis-bestpractices-general-md

    If you would like us to look into the server side to look for any issues, please send us answers to the following questions: https://gist.github.com/JonCole/132b255425268459ec95#file-supportquestionnaire-md. You can send us this information at azurecache@microsoft.com. 

     


    Thursday, April 27, 2017 2:40 PM
  • Thank you very much for detailed reply.

    Unfortunately ConnectionMultiplexer not reconnecting immediately when SSL is enabled.

    It is working after i change the port number from 6380 to 6379 and using the cache service only on http.

    This issue is occurring when i tried to use HTTPS. ok i will try again by changing the Basic Tier cache. 

    I will send you the answer after re-testing again.

    thanks 

    Kalyan

    Wednesday, May 3, 2017 6:46 PM
  • This happens when your port is blocked by firewall.

    Ajit

    Thursday, February 8, 2018 10:07 AM
  • I want to follow up on this thread to see if you are still experiencing issues. Was this a firewall/port issue?

    Thank you,

    Mike

    Wednesday, March 28, 2018 7:40 PM
    Moderator
  • This worked for me, thanks Ajit!  
    Friday, May 10, 2019 5:40 PM