locked
Can't download or update apps since windows phone 8.1 RRS feed

  • Question

  • Hello!
    Two days ago I downloaded the Developer Preview for Windows Phone 8.1. I like the new features but I've been unable to download or update apps since then. The status of the apps is "Pending" for the whole time. If I click on one of those apps, this message comes: "Just a little bit longer and [app name] will be installed." But that's been for 2 days now.

    I hope someone can help me.

    (PS: My Englisch is not perfect since I'm German, please forgive that. :) )

    Thursday, April 17, 2014 8:58 AM

All replies

  • So, after a hard reset everything is finally okay again.
    Thursday, April 17, 2014 2:39 PM
  • I did the exact same thing, and everything worked ok for a while, now my apps wont download again. It just says pending. It seems a hard reset only fixes it for a while. My Data sense also seems to have a problem, it wont open. After a hard reset it was fine, until recently.
    Thursday, April 24, 2014 5:53 PM
  • I have the same problem. After several hard resets, i noticed that the 'pending' issue begins ONLY after i insert a SIM. That is, apps and updates for existing apps download and install as expected UNTIL i insert my SIM. After inserting the SIM, all attempts to update or download result in 'Pending' rather than actually installing. Details: - Nokia Lumia 1320 (factory unlocked) - Bell Mobility, Canada - Windows Phone 8.1 via Preview for Developers - left several pending downloads for an hour and then overnight with no luck -- Peter
    Friday, April 25, 2014 5:27 PM
  • I can't find help on this anywhere, windows phone twitter sent me to these forums. I find it hard to believe no one else is having this issue.
    Saturday, April 26, 2014 2:12 AM
  • Greetings,

    Thank you for posting on the Windows Phone developer forums. I understand that after updating to Windows Phone 8.1 Preview, your apps sit at “pending” when you attempt to update or download them.

    I’d like to get the following information from folks who are experiencing this issue:

    Make and Model:

    Mobile Operator:

    Is the Phone Unlocked?

    Does this happen with free apps, paid apps, or both?

    Are the apps stored on an SD card? If so, what happens if you try moving an app to the phone and update?

    I would also like to know if you have access to a Wi-Fi network? If so, does this issue occur on both Wi-Fi and Data? If you have Wi-Fi available does this issue happen with other Wi-Fi networks?

    Thank you in advance for your reply.

    Best Regards,

    Tim P.

    Saturday, April 26, 2014 7:28 PM
    Moderator
  • Nokia 925

    TELUS Mobility

    Phone is unlocked I believe

    No SD card

    And the problem is over WiFi and my data connection. I was frustrated last might, did a hard reset and didnt restore anything. started from scratch. Downloaded some apps over WiFi and some over data. Everything seemed fine. Got home tonight, tried another app and now its stuck in pending again.

    The apps are both paid and free apps that get stuck. Also updates, like the one for Xbox music and OneDrive

    Not sure if its related, but every time this happens my data sense app won't open either. Just sends me back to the start screen.

    Sunday, April 27, 2014 6:13 AM
  • Hello Tim!

    Answers to all your questions:

    Make/Model: Nokia Lumia 1320
    Mobile Operator: Bell Mobility (Canada)
    Unlocked: Yes
    Free/Paid Apps: both
    Apps Stored on SD Card: No
    Wifi: Yes
    Issue occur on Wifi and Data: Yes
    Other Wifi networks: Yes

    Notes:
    - after a hard reset, apps download/update as expected for a little while but after about an hour it stops working
    - Data Sense works after the hard reset but then fails to open when the ‘Pending’ issue starts
    - Date/Time shows my locale in the App list after a hard reset but becomes blank when the ‘Pending’ issue starts

    --
    Peter

    Sunday, April 27, 2014 4:39 PM
  • im having the exact same issues as peter. although this morning my apps were finally downloading and updating via wifi and my data connection. But this afternoon I'm back to pending. I've done nothing out fo the ordinary this afternoon with my phone except for a few text msgs and web browsing that's all. Also my data sense fails to open. I can view information via the live tile, but the stats aren't updating.
    Sunday, April 27, 2014 6:00 PM
  • I am having the same issues.  OneDrive, Xbox music, Xbox video. FB and diagnostics will not download and have Error code: 80073CF6

    I am using a Nokia Lumia 1520 locked to at&t.

    It seems to be Microsoft apps.  non MS apps install with no problems.

    OneDrive, Xbox Music, Xbox Video & FB were all installed on the phone and would not update.  I uninstalled OneDrive and tried to install in on the SD card and have the same problem.


    RA Vernon


    I am in the US. I tried removing the SD card, but I still have the problem.
    • Edited by RA Vernon Sunday, May 4, 2014 10:57 AM
    Sunday, April 27, 2014 6:20 PM
  • to be clear, my issue is with any app or game, paid pr unpaid. Made mg Microsoft, or the kid on the corner. Stuck on pending.
    Monday, April 28, 2014 1:18 AM
  • Hello:

    Thanks for the details shared by everyone.  I have two more things to ask of anyone having this issue.

    • What country are you located in?
    • If you remove your SIM card, do you continue to have the same issue downloading apps or updating existing apps?

    For anyone that responds to this thread, please provide all the details requested by Tim and the two additional ones in this post.  It is important that this is provided as we are going to track this and want to look for any common threads.

    Mark W.

    Friday, May 2, 2014 1:43 AM
    Moderator
  • Hello,

    Make/Model: Nokia Lumia 525
    Mobile Operator: Reliance (India)
    Unlocked: Yes
    Free/Paid Apps: both
    Apps Stored on SD Card: No
    Wifi: Yes
    Issue occur on Wifi and Data: Yes
    Other Wifi networks: Yes

    I cant install any microsoft apps on my windows phone 8.1

    Friday, May 2, 2014 5:50 AM
  • woah!! Mark I took out my sim card, restarted my phone with my sim card back in and now it works!!!!!!

    also note im in Canada and on telus mobility! Finalllllllly progresss!!

    Friday, May 2, 2014 11:29 PM
  • I am in the US. I tried removing the SD card, but I still have the problem.

    RA Vernon


    • Edited by RA Vernon Sunday, May 4, 2014 10:58 AM
    Sunday, May 4, 2014 10:57 AM
  • I'm in The Netherlands and own an Nokia Lumia 1520 with Windows Phone 8.1 (developer). I'm on the T-Mobile network.  For me both Video and Onedrive will not update or start after the update.

    Here my answers to the questions:

    Make and Model: Nokia Lumia 1520

    Mobile Operator: T-Mobile NL

    Is the Phone Unlocked? Yes

    Does this happen with free apps, paid apps, or both? Only Onedrive and Video

    Are the apps stored on an SD card? If so, what happens if you try moving an app to the phone and update? I cannot find these applications in the storage menu of the phone (this is probably the main issue)... They can be found in my application list, but from there they won't start.

    I would also like to know if you have access to a Wi-Fi network? If so, does this issue occur on both Wi-Fi and Data? If you have Wi-Fi available does this issue happen with other Wi-Fi networks? The issue occurs on both WiFi (all networks, I've tried several) and Cellular

    Country: The Netherlands

    Kind regards,

    Sawan Bruins

    Monday, May 5, 2014 12:42 PM
  • Same problem here.  I can't download or update any apps at all.

    I'm in the U.S.

    Nokia Lumia Icon

    Verizon Wireless (locked)

    No SD card

    I tried both Wifi and Data

    Tuesday, May 6, 2014 5:42 PM
  • Having the same issue with my concert app. Other users can't download either, it has essentially bricked every user, because they can't downgrade to the 7.1 version anymore.

    Make/Model: Nokia Lumia 928 / Lumia 920
    Mobile Operator: Verizon (USA) / No Sim 
    Unlocked: Yes / Yes
    Free/Paid Apps: Free
    Apps Stored on SD Card: No / No
    Wifi: Yes
    Issue occur on Wifi and Data: Yes
    Other Wifi networks: Yes

    Wednesday, May 7, 2014 12:48 AM
  • my issue is back. Pulling the sim card worked once, now everything is back to pending. Anyone having any luck? It has to be tied into the data sense. Because as soon as I recive pending in the store data sense stops working as well.
    Monday, May 12, 2014 3:06 PM
  • That makes sense to me as well.  unfortunately there seems to be no support for this issue whatsoever.  hopefully when 8.1 officially launches it will be ironed out.  that's my last hope, lol.
    Tuesday, May 13, 2014 12:01 AM
  • Well I just downloaded the latest update and still doesn't work. This is awful because the store is useless to me now :(
    Wednesday, May 14, 2014 8:29 PM
  • Might be worth doing another Hard Reset after the update.  I did one (again) shortly before the latest update and things are still operating normally.  Hopefully it stays that way, but I'm not very optimistic.
    Thursday, May 15, 2014 1:32 AM
  • It might also be worth noting that when the app store/data sense problem exists, my email/calendar/contacts won't automatically sync.  They will if I manually press "sync" but it is set to "as items arrive" and I even tried setting the sync settings to "every 15 mins" but it still wouldn't sync without me manually asking it to.  Sounds like there is something blocking downloads and other data usage.

    It could be coming from data sense, but it might also be from some other source that is trying to "protect" us from using cellular data and maybe isn't recognizing we are connected to wifi.  I had a seemingly unrelated issue when I first upgraded to 8.1, it said it wouldn't complete the update until I was connected to wifi (which I already was) so I had to manually tell it to go ahead anyway because I knew it must have been mistaken.  Turns out it was mistaken because when it completed the update, it downloaded everything from wifi (verizon tracked my data usage and there was no increase whatsoever).  So despite the phone being connected to, and using wifi, maybe it doesn't recognize it's connection and therefore won't update our apps until we do connect due to some setting.  Now I already changed the setting that I could find regarding updating apps over wifi (I set it to allow downloads over cell data) but that didn't help.  But with outlook/mail/people not syncing, apps not downloading, and data sense crashing every time you try and open it, it really sounds like the issue lies with wifi recognition or cell data permissions.  

    To avoid confusion, my phone DOES say it's connected to wifi, and when I use the internet or anything else, it all comes from wifi.  My only evidence for my phone's wifi confusion is when I initially updated to 8.1 and it said I wasn't connected when I knew I was.  Even the status bar reflected that I was connected with a strong signal to wifi, but the update software (?) claimed I wasn't.  And it was wrong.

    Also, just for the sake of preventing confusion, I have tried to run on only cell data and all my problems persist.

    Perhaps someone who knows a bit more about phones/windows phones/cell data/wifi can shed light on the issue.

    Thursday, May 15, 2014 1:48 AM
  • the email sync issue is also related I think! I just noticed this as well. This is crazy that we've gotten no support in this.
    Friday, May 16, 2014 1:49 AM
  • Greetings all,

    Thank you for your reply. We will be looking into this issue and will be in touch if there are any other steps we need you to take or anything information we need from you.

    Best Regards,

    Tim P.

    Friday, May 16, 2014 7:21 PM
    Moderator
  • vAfter a few tests and hard resets this weekend, Ben seems to be right. I have data. But it seems only forced data. Emails, live tiles, downloads don't work. But if I force an email update it works, if I open the app where my live tiles not updating like AccuWeather it works, and if I open IE I can browse all day long.data sense won't open and like I stated before the live tile seems to keep track of my WiFi usage but my regular data it shows 0 through the live tile which isn't accurate.
    Monday, May 19, 2014 3:03 AM
  • It might also be worth noting that when the app store/data sense problem exists, my email/calendar/contacts won't automatically sync.  They will if I manually press "sync" but it is set to "as items arrive" and I even tried setting the sync settings to "every 15 mins" but it still wouldn't sync without me manually asking it to.  Sounds like there is something blocking downloads and other data usage.

    It could be coming from data sense, but it might also be from some other source that is trying to "protect" us from using cellular data and maybe isn't recognizing we are connected to wifi.  I had a seemingly unrelated issue when I first upgraded to 8.1, it said it wouldn't complete the update until I was connected to wifi (which I already was) so I had to manually tell it to go ahead anyway because I knew it must have been mistaken.  Turns out it was mistaken because when it completed the update, it downloaded everything from wifi (verizon tracked my data usage and there was no increase whatsoever).  So despite the phone being connected to, and using wifi, maybe it doesn't recognize it's connection and therefore won't update our apps until we do connect due to some setting.  Now I already changed the setting that I could find regarding updating apps over wifi (I set it to allow downloads over cell data) but that didn't help.  But with outlook/mail/people not syncing, apps not downloading, and data sense crashing every time you try and open it, it really sounds like the issue lies with wifi recognition or cell data permissions.  

    To avoid confusion, my phone DOES say it's connected to wifi, and when I use the internet or anything else, it all comes from wifi.  My only evidence for my phone's wifi confusion is when I initially updated to 8.1 and it said I wasn't connected when I knew I was.  Even the status bar reflected that I was connected with a strong signal to wifi, but the update software (?) claimed I wasn't.  And it was wrong.

    Also, just for the sake of preventing confusion, I have tried to run on only cell data and all my problems persist.

    Perhaps someone who knows a bit more about phones/windows phones/cell data/wifi can shed light on the issue.


    Same exact issue with my Nokia 920, ATT locked.
    Tuesday, May 20, 2014 12:32 AM
  • I am only having the issue with Facebook app.

    Make/Model: Nokia Lumia 1090/Although about us says 909?
    Mobile Operator: AT&T
    Unlocked: No
    Free/Paid Apps: other apps have worked, so far just Facebook update
    Apps Stored on SD Card: No
    Wifi: Yes
    Issue occur on Wifi and Data: Yes
    Other Wifi networks: Yes

    Have uninstalled and tried reinstalling. Consistently get 80073cf6 error.

    Tuesday, May 20, 2014 2:24 AM
  • Hello David and others:

    Thank you for the continued feedback.  At this point the only additional suggestion I have is for those that use a SD card in their phone.  I have seen some reports of customers having issues installing/updating apps while an SD card is in the phone.  I might suggest you remove your SD card and then reboot your phone.  When the phone reboots, connect and try to install/update your apps.  If this is successful, then add the SD card back to the phone and reboot one more time.

    Please let us know if you have any other questions or concerns.

    Mark W.

    Saturday, May 24, 2014 10:19 PM
    Moderator
  • Hello David and others:

    Thank you for the continued feedback.  At this point the only additional suggestion I have is for those that use a SD card in their phone.  I have seen some reports of customers having issues installing/updating apps while an SD card is in the phone.  I might suggest you remove your SD card and then reboot your phone.  When the phone reboots, connect and try to install/update your apps.  If this is successful, then add the SD card back to the phone and reboot one more time.

    Please let us know if you have any other questions or concerns.

    Mark W.

    Well the "pending" downloads problem is not the only problem here.  Something (likely within Data Sense) is blocking us from the entire Microsoft ecosystem.  I just hard booted my phone again, and afterwards it behaves as it should, flawlessly.  However, after about 24 hours the problem resumes.  Email (Hotmail) won't sync automatically, calendars won't sync automatically, the store won't download (forever pending), all live tiles cease to be live until you open them to refresh, data sync won't open at all, maps (bing) won't load at all unless you downloaded them during the "window of productivity" after a hard reboot, and you cannot download maps after the "window of productivity" closes.  All the settings that I could find that restrict the use of data (roaming/not on wifi/etc.) have been opened to allow as much data usage as possible.  Unless there are more data settings somewhere that I'm not seeing, then there is nothing that we, the user, can do to remedy this.

    I don't have a phone that supports an SD card. I'm a Verizon Wireless customer using Verizon 4g LTE data as well as Wifi.  

    I really hope that this gets resolved, otherwise I will have to make a change in the near future.

    Sunday, May 25, 2014 12:23 AM
  • Okay, this might sound crazy, but I think I found a solution.  I reset my phone Saturday morning and it is still working (knock on wood).  This is the longest it has worked after a hard reset.  So what I did differently this time is after the reset, under settings>backup>photos+videos I set everything to "don't upload."  

    Previously I always had it set at "Best Quality (needs Wi-Fi)" and since I changed it my phone works!  I think that with the way I had it set before, my phone would work until I took a picture.  The pictures I took still were uploaded, but that would explain why my phone randomly would start with this issue after a hard reset.  I could test this, but I don't really care to do another hard reset if I'm right (although being right would bring a bit of satisfaction, lol).

    So just thought I would let you guys know that I'm currently 5 days into it and my phone is operating as expected (minus the auto upload feature, obviously).

    And to Microsoft, maybe you could look into that feature and find what's wrong.  Again, this is only after updating to 8.1.  On WP8, I had no issues whatsoever and my photo/video backup settings were always set to "best, needs wifi."

    I'll update if anything changes, best of luck!

    • Proposed as answer by Ben McAwesome Thursday, May 29, 2014 4:22 AM
    Thursday, May 29, 2014 4:22 AM
  • Hello:

    Thank you for posting your solution here.  I would like to encourage others that had this issue to try Ben's steps to see if this also resolves things for you.  If we can get some further confirmation that the auto uploading of pictures leads to this behavior, we will certainly look into why that is so.

    Please let us know if you have any other questions or concerns.

    Mark W.

    • Proposed as answer by Phil J W Saturday, May 31, 2014 3:52 AM
    • Unproposed as answer by Phil J W Saturday, May 31, 2014 3:52 AM
    Friday, May 30, 2014 6:08 AM
    Moderator
  • So after my last reset I skipped the backup portion of the setup and evidently I'm on 9 days of no issues. I didn't realize that was the reason for the fix until ben pointed it out and I looked at my settings. I like all the other times assumed that one of these days id just get "pending" again....

    Saturday, May 31, 2014 3:51 AM
  • Ben, I think you'd found the solution. I've been fighting with my HTC 8x since 8.1 where the store doesn't even load at all. Gone through countless hard resets, tried downgrading, basically tried everything under the sun. After applying your little tip, I've been able to get into the store every single time.
    Tuesday, June 3, 2014 8:54 PM
  • Mark, Ben's solution was the only thing that allowed me to get back into the Store on my 8x.
    Tuesday, June 3, 2014 9:02 PM
  • Have installed the latest update of windows 8.1 version 8.1.12393.890 in my Lumia 520

    And now when i try to download any app from the store, it starts downloading at first, then it says attention required.

    I tried to download the same many a times but something happens and it stops downloading.

    Uninstalled an app and tried to reinstall it.. and even that wont happen now -_-


    Wednesday, June 4, 2014 9:41 AM
  • Have installed the latest update of windows 8.1 version 8.1.12393.890 in my Lumia 520

    And now when i try to download any app from the store, it starts downloading at first, then it says attention required.

    I tried to download the same many a times but something happens and it stops downloading.

    Uninstalled an app and tried to reinstall it.. and even that wont happen now -_-


    hi, me too have the same problem, it says me error 80073cf6.. Have u solved the problem? How? Thank u!
    Thursday, June 5, 2014 12:04 AM
  • hej, i have the same problem, error 80073cf6, since I have the 8.1 preview I can't download/update many apps (for example transfer my data, videomomenti, video editor 8.1, bing health, Nokia treasure tag, file manager..). I have a Lumia 920, country Italy, language Italian, operator Vodafone. I have this problem both in WiFi and data, do you know solutions? Thank you, I'm sorry for my English!
    Thursday, June 5, 2014 12:25 AM
  • Make sure that your date and time is set correctly
    Sunday, June 8, 2014 6:18 AM
  • Tried the removal of automatic upload of photos+videos, still with no result.

    Has there been a permanent fix to this yet?

    I'm running at Nokia Lumia Icon on Verizon's network, however I'm in Alaska on an "extended network." That shouldnt have anything to do with it though, because i'm able to get onto secure wi-fi networks at work and at home.

    Someone please help. this is really annoying.

    Wednesday, June 11, 2014 10:25 PM
  • Hey Guys, I've been dealing with the same problem for quite a while now.

    Only thing I found in other sites that can help Microsoft folks is that maybe it's a problem between 8.1 and SD cards that are Class 4. It seems 8.1 needs something faster... I'm only afraid it's true and there's tons of class 4 out there... Would you check yours???

    After latest update earlier today, several app issued on the card are under a "installing" status. When I look at storage sense, there are 7G in the Other folder and those are not listed in the apps folder.

    Make/Model: Nokia Lumia 820
    Mobile Operator: Vivo Brazil
    Unlocked: Yes

    Free/Paid Apps: both
    Apps Stored on SD Card: Yes

    Wifi: Yes
    Issue occur on Wifi and Data: Yes
    Other Wifi networks: Yes

    • Edited by Haryston Saturday, June 14, 2014 6:44 AM
    Saturday, June 14, 2014 6:37 AM
  • Tried the removal of automatic upload of photos+videos, still with no result.

    Has there been a permanent fix to this yet?

    I'm running at Nokia Lumia Icon on Verizon's network, however I'm in Alaska on an "extended network." That shouldnt have anything to do with it though, because i'm able to get onto secure wi-fi networks at work and at home.

    Someone please help. this is really annoying.

    What part of Alaska? I'm in Juneau and I'm having this problem.  I also have the Lumia Icon on Verizon (using extended network (ACS)).  but turning off auto backups did seem to solve my problem for a couple of weeks.  Then it did a phone settings backup (sneaky) and the problem resumed.  So I shut off every form of backup, auto upload, and send info to microsoft or whoever that I possibly could.  seems to be working again.
    Tuesday, June 17, 2014 3:06 AM
  • Same situation as many of you. Started happening a week ago. Had 8.1 for several weeks and was working fine before then.

    • All updates and app downloads are pending "Just a little bit longer and ______ will be installed."
    • Email won't automatically sync (though sometimes it does)
    • Automatic set time is incorrect. Need to set time manually.
    • Can't open data sense

    Hard resets and disabling back-ups haven't helped at all. Would REALLY appreciate a bug fix from Microsoft!!! Thanks.

    • Edited by btwilson Friday, June 20, 2014 3:49 PM
    Friday, June 20, 2014 1:33 PM
  • I have the same problem after I updatet the Preview. The Data Sense App crashes when starting and I cant download or update apps anymore. Is there no way to fix this problem. im really getting angry now >:(
    Saturday, July 19, 2014 2:39 PM
  • Hello, I'm having similar 'pending' status with 18 of my apps currently. I've tried updating one at a time, soft-resets, taking out the SIM card, connecting and disconnecting from the WiFi, and turning off the auto-upload thing Ben had suggested. The problem isn't just with Microsoft apps either. Not sure where to go from here. Just got the 8.1 update two days ago and have been the issue since.

    Make and Model: Nokia Lumia 925

    Mobile Operator: Straighttalk

    Is the Phone Unlocked? No

    Does this happen with free apps, paid apps, or both? So far just free apps

    Are the apps stored on an SD card? Nope

    I would also like to know if you have access to a Wi-Fi network? Very nice reliable WiFi

    If so, does this issue occur on both Wi-Fi and Data? Yes

    If you have Wi-Fi available does this issue happen with other Wi-Fi networks? Yes it does.

    What country are you located in? Alaska, USA

    If you remove your SIM card, do you continue to have the same issue downloading apps or updating existing apps? Yes

    Tuesday, July 22, 2014 12:08 AM
  • Lumia 920 t-mobile unloked DP waiting cyan, cause i use it in Italy , error 80073cf6 on all Microsoft apps like Fb beta, new lockscreen app etc. Tryed some solutions , toggle photo upload , soft resets etc i think is a problem of Microsoft apps on unlocked devices , it's impossible that there isn't a solution , keep following th this post waiting For a fix.
    Sunday, July 27, 2014 3:26 PM