none
Timeouts and connection problems when using FTPS upload to Azure

    Question

  • A number of our customers use FTPS to upload to Windows Azure websites (the FTPS publishing feature provided by Windows Azure for web site publishing). And they report consistent timeouts and upload issues, regardless of the FTP/FTPS client they use. 

    FTP publishing seems OK, it's just a problem with FTPS publishing. 

    Here is an example:

    INFO [FTPConnection] 20 Feb 2014 10:03:13.803 : FTPConnection.1Auto FEAT disabled
    ---> TYPE I
    ---> PWD
    INFO [FTPSynchronizer] 20 Feb 2014 10:03:14.548 : FTPConnection.1Synchronize C:\tmp\OldTentacle with /site/wwwroot/d
    ---> CWD /site/wwwroot/d/
    ---> CWD /
    ---> CWD /site/wwwroot/d/
    ---> PWD
    ---> SYST
    ---> PWD
    ---> PASV
    INFO [SSLFTPSocket] 20 Feb 2014 10:03:16.732 : FTPConnection.1Connecting to 168.62.232.17:10080 with timeout 600000 ms
    ---> LIST
    ---> CWD Azure
    ---> PWD
    ---> PWD
    ---> PASV
    INFO [SSLFTPSocket] 20 Feb 2014 10:03:20.694 : FTPConnection.1Connecting to 168.62.232.17:10194 with timeout 600000 ms
    ---> LIST
    WARN [SocketController] 20 Feb 2014 10:05:31.320 : FTPConnection.1OnReceive - (An existing connection was forcibly closed by the remote host) - closing

    Note that we hung on the LIST command for two minutes before Azure terminated the connection, and no bytes were transferred. I can reproduce this consistently all last night and this morning, so I don't think it's a temporary issue. File uploads are also flaky - if I try to upload 500 files around 1MB or less in size, approximately half of them will fail. 

    There are no proxies/firewalls between the client and the internet. 

    I've tried changing SSL protocols between SSL3, TLS1 and TLS1.1, and the same behaviour occurs when I use either FileZilla or a .NET FTP component. 


    • Edited by Paul Stovell Thursday, February 20, 2014 12:13 AM
    Thursday, February 20, 2014 12:12 AM

Answers

All replies

  • Hi Paul,

    was this FTPS connection working before?

    ~Vishal


    Vishal Narayan Saxena http://twitter.com/vishalishere http://www.ogleogle.com/vishal/

    Thursday, February 20, 2014 12:21 AM
  • Hi Vishal,

    When I first tested with FTPS (last year) it seemed OK. But this is a brand new Windows Azure website in the US North Central website (created about 12 hours ago) that is experiencing the problems. And it's not limited to this website - other users experience the same problem. 


    • Edited by Paul Stovell Thursday, February 20, 2014 12:29 AM
    Thursday, February 20, 2014 12:27 AM
  • Hi Paul,

    There is a know issue which will be available in next update. As a workaound, you can try the kudu console to download/upload files which is SSL ENABLED as well.

    For publishing, both msdeploy or GIT are HTTPS.

    Sorry for this inconvenience.

    Thursday, February 20, 2014 10:10 AM
    Moderator
  • Great to know why, thanks! 
    Thursday, February 20, 2014 12:07 PM
  • sorry for the convenience. This issue is client related, my colleague told me FTPS works, in case you want a try.

    http://ftps.codeplex.com/)


    Friday, February 21, 2014 1:16 AM
    Moderator
  • We are having exactly the same symptoms.  Almost 2 years of consistent success using FTP to update files on our Website deployments.  But starting on Monday (7/14) we cannot reliably connect, list, put or get more than maybe a file or two before we get into what I call "timeout jail."  We have tried several clients including the FTPS client recommended above, FileZilla, Windows command line FTP client and Windows Explorer.  Also tried FileZilla on OS X.  And then tried several Windows FTP clients on a brand new VM inside Azure, and two home locations.  Every combination provides the same result...connect, attempt to list, sometimes you get the list and sometimes you don't but by the time you try to PUT or GET a file or LIST again, timeout and disconnect hell begins.

    Any help or workarounds would be appreciated.  We are stuck and cannot update our production websites any more.

    Wednesday, July 16, 2014 4:33 PM
  • We are having the exact same problem (FTPS) and this prevent us from deploying automatically which causes us servere organization problems.

    Could you please tell me when this will solved? 

    Friday, September 5, 2014 8:22 AM
  • Same here. Timeout when I try to do a write operation (rename, delete, upload) on my azure website using FTP or FTPS.
    Sunday, September 28, 2014 8:34 AM
  • I hope a six year old console client is not really microsofts reference of a programm we should use for uploading files!
    btw the problem still exists!
    Monday, September 28, 2015 7:57 AM
  • Ok, tried your "Alex FTPS" console programm. Didn´t work, just like WinSCP and FileZilla. Regardless wich client I use I got timeouts from the server side. Face it: It´s not a client bug!
    • Edited by Marc Militz Monday, September 28, 2015 8:08 AM
    Monday, September 28, 2015 8:08 AM