The following forum(s) have migrated to Microsoft Q&A (Preview): Azure Virtual Machines!
Visit Microsoft Q&A (Preview) to post new questions.

Learn More

Enabling port for net.tcp communication in Azure VM RRS feed

  • Question

  • I have created a Windows WCF Service and I want to host it inside Azure VM.

    The service is locally running fine inside the VM, but when attempting to access the service outside of the VM, I cannot connect to the service at the specified port.

    While requesting the service, I'm getting the following error:

    SocketException (0x274d): No connection could be made because the target machine actively refused it...

    Also, while pinging the VM through the command prompt with public ip, I'm getting Request timed out.

    I have enabled the port for TCP in Azure inbound rules as well as in VM firewall inbound rules. The VM is Windows Server.

    How can I access the service running in the VM from another system?

    Monday, November 25, 2019 4:08 PM

All replies

  • Hi,

    Make sure that no other service is using the same Port. 

    Monday, November 25, 2019 7:53 PM
  • Hello,

    Any update on the issue?

    If the suggested response helped you resolve your issue, do click on "Mark as Answer" and "Up-Vote" for the answer that helped you for benefit of the community.

    Wednesday, November 27, 2019 10:32 AM
  • Hello,

    Any update on the issue?

    Tuesday, December 3, 2019 4:36 PM