MABS SMTP Config RRS feed

  • Question

  • Hi,

    I am trying to configure MABS to send notifications however I'm failing to config authentication.

    I am using service called sendgrid which is an external SMTP server allowing us to configure any 3rd party application to use it no matter where they are hosted without having to add additional SPF record every time.

    The issue I'm getting i'm running into is authentication.

    For some reason MABS always return invalid username and password. I'm having a feeling that it's due to sendgrid expecting PLAIN authentication method and MABS is using something else. 

    My question is - Are my assumptions right and if yes what are my options here as I really need this configured against sendgrid.


    Monday, June 17, 2019 8:39 AM

All replies

  • Hi Arturs Kirsis,

    AFAIK it doesn’t use / require any encrypted credentials as such for SMTP server. I would suggest you to double check below things and see if you can send notifications without issues.

    1. provided username's domain is same as domain that MABS is on.
    2. SMTP server name, port number are correct and valid.
    Thursday, June 20, 2019 10:31 AM
  • Thanks but I don't think that the initial question was read correctly.

    We are using external service called sendgrid, we do not run on-prem exchange, we only have O365 Exchange which I don't think can be used with MABS.

    Thursday, June 20, 2019 11:49 AM
  • Hi Arturs Kirsis,

    Apologize if it was confusing. Perhaps I am missing something but based on given information, I get that your question was for SendGrid but my intention was lets say domain that MABS is on is and lets say used SMTP server name is something like and used username is something like then have that setup configured and try to test send notification part.

    Based on your recent response regarding your usage of O365 account, I would suggest you to refer this article which talks about setting up email notifications using an Office 365 account and that might be related to what you are looking for.
    Friday, June 21, 2019 11:18 AM
  • Hi,

    I am a colleague of Arturs and just want to clarify what he is asking.

    1. MABS has an SMTP configuration area where you can supply SMTP details and credentials.

    2. We would like to put our SendGrid SMTP details in there.

    3. MABS rejects them saying that the username and password is incorrect.  This is not the case.

    I suspect MABS is making some assumptions about the environment and that is why it is failing.  I suspect it is assuming the user is a domain user and is attempting to validate this against the domain.  In our case, this is incorrect as we are using SendGrid's SMTP service.

    To back this theory up, I have used WireShark and it does appear that MABS is attempting to do an LDAP lookup for the user.  This will not work when using a service such as SendGrid.
    • Edited by gregpakes Monday, June 24, 2019 4:44 AM
    Monday, June 24, 2019 4:43 AM
  • The SMTP user account should be domain account. This is documented in the below article. The workaround is to configure IIS as SMTP relay.

    Tuesday, July 2, 2019 5:02 AM
  • That is really disappointing.

    Can I ask why it needs to be a domain account?  It means that I can't use a service like SendGrid.

    Tuesday, July 2, 2019 5:09 AM
  • Its a prerequisite. See the link - for more details on MABS management support.

    Tuesday, July 2, 2019 9:23 AM
  • Apologies - Where is it a pre-requisite?

    I don't see anywhere where it says that the SMTP user must be a domain user as an LDAP lookup will occur.

    Tuesday, July 2, 2019 9:26 AM
  • To install MABS the machine needs to be a domain joined. Regarding SMTP, the information is already mentioned in the troubleshooting guide.

    Tuesday, July 2, 2019 9:40 AM
  • Hi,

    I am not arguing about whether the machine needs to be domain-joined.  It is domain joined.

    Can you point me towards where it says that the SMTP user needs to be a domain user?  I can't see this.  And I am curious as to why this is the case?  It seems like a pointless check...


    Tuesday, July 2, 2019 9:57 AM
  • This is by design! And workaround to use IIS SMTP relay should solve the problem.
    Wednesday, July 3, 2019 9:34 AM
  • I realise it's by design.  I'm asking why?
    Wednesday, July 3, 2019 9:37 AM
  • Why it is designed that way, is something that I cannot answer. If you need further investigations on this, I suggest you open a support request and the respective team would be able to give you more details on the same.

    Tuesday, July 9, 2019 9:38 AM