none
msExchHideFromAddressLists attribute isnt syncing across to Azure RRS feed

  • Question

  • We were using dirsync before and upgraded to AD Azure Sync.  Before the upgrade, the attribute "MsExchHideFromAddressLists" was syncing across.  After the upgrade, it is no longer syncing.  What I'm curious of - do I need to check the box for Hybrid Exchange in the Directory Sync Config tool for that attribute to sync? We aren't using exchange on premise anymore, but haven't retired it yet until mid march to make sure everyone was successfully migrated to O365.

    Any help would be greatly appreciated! Microsoft support has been scratching their head at the first level for the last 4 days..

    Thanks!

    Tuesday, January 20, 2015 11:09 PM

Answers

  • Greetings!

    List of Attributes synchronized to Azure AD: https://msdn.microsoft.com/en-us/library/azure/dn764938.aspx


    To add it in the "hide from address lists" capability, open Synchronization Rules Editor, go to Inbound Rules, then find "In from AD - User Common" and click Edit.

    Go to Transformations, Add a Transformation with a Direct flow type, a Target Attribute of msExchHideFromAddressLists, and a source of msExchHideFromAddressLists. Save it.

    Now run an AAD synchronization. You may need need to change the attribute from FALSE back to TRUE for AAD Sync to detect the delta change.

    Thank you,

    Arvind


    Wednesday, March 11, 2015 8:13 AM

All replies

  • Works fine for me.

    Have you configured any of the "selective attribute sync" related functionality? Do you see the attribute being pushed out to WAAD when looking at the connector in MIISClient? When you browse the object in the Metaverse, can you see the MsExchHideFromAddressLists attribute listed? In MIISClient, under Connectors, local AD connector, Attributes, can you see the MsExchHideFromAddressLists attribute and is the checkbox next to it selected?

    Wednesday, January 21, 2015 10:24 AM
  • No, none of the selective attributes were changed or configured.  The attribute does not show up in the metaverse list of attributes when I browse the objects.  I see it on the AD side, and the rules all show they match up target and source for that attribute as well.  Under connectors, local AD connector, attributes, it shows up there and is checked.
    Wednesday, January 21, 2015 3:25 PM
  • Check the Sync rules then. From the Sync rule editor, locate the "In from AD - User Exchange" rule and check the mappings. Is the MsExchHideFromAddressLists listed there?

    Or via PowerShell:

    (Get-ADSyncRule | ? {$_.name -eq "In from AD - User Exchange"}).AttributeFlowMappings | ? {$_.Source -like "*MsExchHideFromAddressLists*"}

    Wednesday, January 21, 2015 3:44 PM
  • Source                : {msExchHideFromAddressLists}
    Destination           : msExchHideFromAddressLists
    FlowType              : Direct
    ExecuteOnce           : False
    Expression            :
    ValueMergeType        : Update
    MappingSourceAsString : msExchHideFromAddressLists

    That's what I get back

    Wednesday, January 21, 2015 4:28 PM
  • Greetings!

    List of Attributes synchronized to Azure AD: https://msdn.microsoft.com/en-us/library/azure/dn764938.aspx


    To add it in the "hide from address lists" capability, open Synchronization Rules Editor, go to Inbound Rules, then find "In from AD - User Common" and click Edit.

    Go to Transformations, Add a Transformation with a Direct flow type, a Target Attribute of msExchHideFromAddressLists, and a source of msExchHideFromAddressLists. Save it.

    Now run an AAD synchronization. You may need need to change the attribute from FALSE back to TRUE for AAD Sync to detect the delta change.

    Thank you,

    Arvind


    Wednesday, March 11, 2015 8:13 AM
  • Hello,

    I am having the same issue here. We have a few Distribution groups in on-prem AD that are mail-enabled in on-prem exchange. In O365, owner/membership, email addresses, etc are all syncing correctly. However, We have turned on 'Hide from address lists" in on-prem EAC and that is not syncing to O365. I followed your instructions here, except that I chose to edit "In from AD - Group Common", since I'm trying to sync an attribute for groups. I get as far as adding a new Transformation. I am able to select msExchHideFromAddressLists as the Target Attribute, but that does not show up as an option under Source. I only see a few options that start with msExch.

    Wednesday, January 11, 2017 7:16 PM
  • In which order did you do things? Did you install Connect before you installed Exchange? Connect will cache the AD schema from the time when it was installed. If you've added Exchange after Connect, then run a refresh directory schema so Connect has the possibility to refresh its schema cache:

    https://docs.microsoft.com/en-us/azure/active-directory/connect/active-directory-aadconnectsync-installation-wizard#refresh-directory-schema

    Thursday, January 12, 2017 8:24 AM
  • I ran into this with a domain that at one time was a SBS 2008 system with local Exchange that had been migrated. 

    I had one resource mailbox (a conference room) that no matter what I did it would not update that checkbox.
    I tried the above but it still did not work.

    I began a comparison with two other conference rooms that had updated and worked as desired (to hide them from the address book as I was going to rebuild them after an office relocation) and looked at the differences between the working/non-working as far as the AD Attributes in AD Users and Computers.

    What I found was the one room that would not sync and update that checkbox was clearly the original room I setup years ago at a time when there was only one conference room. I had at some point either cleared or never made an entry in the E-mail field on the General Tab for the resource.

    Once I populated that value in the E-mail field (which updated and made an entry in the Attribute Editor tab named 'mail') and forced a AD Sync the checkbox was then checked in O365.

    In O365 the resource had an e-mail address, but in the sync'd domain it did not. Perhaps residual due to how I set it up 7 or so years ago, or perhaps because I may have cleared the 'E-mail' value on the 'General' tab... but no matter what it was fixed by getting a value in there.

    Tuesday, September 26, 2017 4:15 AM
  • Thanks for this, it worked great for me, I did a full initialisation sync via powershell Start-ADSyncSyncCycle -PolicyType Initial took a while but the GAL it clean now.
    Sunday, July 7, 2019 1:26 PM