none
Azure Database for PostgreSQL server - max_prepared_transactions RRS feed

  • Question

  • Hi,

    I've created new database using Azure Database for PostgreSQL. Using Azure Portal and management page of the azure database I changed value of max_prepared_transactions to 20 (Settings -> Server parameters). The issue is that I can't see this change in postgresql.  If I execute show max_prepared_transactions then the value is still zero. Do I have to restart service on my own? I checked in Azure Portal but don't see restart option for PostgreSQL service.

    Tuesday, January 9, 2018 9:56 PM

Answers

  • max_prepared_transactions is now available to be configured in Azure Database for PostgreSQL. You can use the Azure portal: https://docs.microsoft.com/azure/postgresql/howto-configure-server-parameters-using-portal
    or Azure CLI to edit: https://docs.microsoft.com/azure/postgresql/howto-configure-server-parameters-using-cli

    If you are using read replicas, max_prepared_transactions on the replica should be equal or greater than on the master, per Postgres 
    https://www.postgresql.org/docs/current/runtime-config-resource.html#RUNTIME-CONFIG-RESOURCE-MEMORY
    Thursday, June 13, 2019 7:35 PM

All replies

  • Hi Mateusz,

    We don't allow this parameter to be updated, and this shouldn't be showing up on the list. Looks like a bug on our end and we're working on fixing this. Yes, this does require a restart and we don't allow that for our service today.

    Thanks for reporting the issue. If you have any further questions or requests, please send me an email at saloni(dot)sonpal(at)microsoft(dot)com. I'd be more than happy to help enable your scenario.

    Best,

    Saloni

    Thursday, January 11, 2018 10:58 PM
  • max_prepared_transactions is now available to be configured in Azure Database for PostgreSQL. You can use the Azure portal: https://docs.microsoft.com/azure/postgresql/howto-configure-server-parameters-using-portal
    or Azure CLI to edit: https://docs.microsoft.com/azure/postgresql/howto-configure-server-parameters-using-cli

    If you are using read replicas, max_prepared_transactions on the replica should be equal or greater than on the master, per Postgres 
    https://www.postgresql.org/docs/current/runtime-config-resource.html#RUNTIME-CONFIG-RESOURCE-MEMORY
    Thursday, June 13, 2019 7:35 PM