locked
Cannot view Folders in View Solution Explorer, yet Folder exists on hard drive as part of the solution. RRS feed

  • Question

  • A folder is not showing up in solution explorer, yet exists on hard drive as part of solution. Here is the scenario:

    Yesterday I checked in in some code to TFS which included a folder with two files. I did not do a "get recursive" to get all updates, since no one else had done any updates to that solution. Today I checked in some more code, but had to go through the merge process, since someone else had updated the solution on TFS since I checked in my code yesterday. After going through that and checking my  code in, I then did a get recursive so that I could get all other updates that the other developer had loaded to TFS for the solution in question.  

    Then, after attempting a build on my hard drive, it failed because the folder with two files that I had checked in yesterday was missing in solution explorer. Yet, the folder plus the two files exist on my hard drive as part of the solution when I search using windows explorer.

    Why does this happen and what can I do to fix it?

    Thanks!

     

     

    Friday, April 8, 2011 6:10 PM

Answers

  • Sounds like someone else checked in a version of your project without a reference to those folders.  This is how you can fix it:

    On you solution explorer, click on the "Show All Files" icon, which is the second from the left.  Your "missing" files and folders will now show up, but will be grayed out.  Right-click on them and select "Include in Project".

    Check-in.

     

     


    Esteban Garcia - My blog
    Monday, April 11, 2011 2:02 AM

All replies

  • Hi,

    The files are exist in both you machine and TFS? if yes, check the solution file may some other developer change the sln file so your file not part of the solution but it should be in version control in TFS.

    And to make sure you have the same version of the code in the server:

    • Backup your local copy.
    • Delete local version of the code.
    • Delete TFS cash from [C:\Documents and Settings\USDRID\Local Settings\Application Data\Microsoft\Team Foundation].
    • Get latest version from server and do check.

     

    Thanks


    Regards Ayman Zaza MCTS
    Sunday, April 10, 2011 1:03 PM
  • Sounds like someone else checked in a version of your project without a reference to those folders.  This is how you can fix it:

    On you solution explorer, click on the "Show All Files" icon, which is the second from the left.  Your "missing" files and folders will now show up, but will be grayed out.  Right-click on them and select "Include in Project".

    Check-in.

     

     


    Esteban Garcia - My blog
    Monday, April 11, 2011 2:02 AM
  • Hi Rkwr,

     

    Thanks for your post.

     

    For this issue, as Ayman and Estenban said, it seems those folders lost some reference relationship under this solution. Please try to show them under the solution as Esteban’s suggestion.


    John Qiao [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, April 11, 2011 4:35 AM
    Moderator
  • Perfect solution! Save me from my dead loop just looking one key file!
    Monday, September 11, 2017 3:25 AM
  • This is a great solution.

    Is there any way to do this in reverse? For example if I delete files in Windows File Explorer can I update my solution and have it remove those files? Instead of manually having to go in and remove each one individually?
    Wednesday, November 29, 2017 7:53 PM