none
Unable to use dataset parameters

    Question

  • Hi there,

    I would like to use dataset parameter for multiple csv ingestion. My parameter is a delimiter as my csv's get different delimiters : https://ibb.co/JypP6K0

    The preview data feature works without calling the parameter : https://ibb.co/8g3VbsJ

    But throw an error when adding the parameter to the delimiter value: https://ibb.co/kS9QJBR

    Text error is : Failed to convert the value in 'columnDelimiter' property to 'System.String' type. Please make sure the payload structure and value are correct.

    I found a similar error on the forum, about spaces in dataset name but here there is no spaces.

    Any idea why ? Am I missing something ? Thanks in advance for your help


    • Edited by Florian Hamon Thursday, May 16, 2019 1:58 PM added details
    Wednesday, May 15, 2019 8:36 PM

Answers

  • Hello Florian Hamon and thank you for your inquiry.  I have reproduced your situation.  Thank you for the pictures and details.  I also tried something else.  I published and ran in production, and it succeeded, even though the preview didn't work.  Running in debug also succeeded.

    Given the text of the error saying "System.String", and that it worked when run, I suspect that this has to do with the ability to override the default parameter.  Without running, the alternate value is unresolved.

    The important part, is that even though the preview data feature is buggy in this case, your pipeline will still run.


    Friday, May 17, 2019 10:03 PM
    Moderator

All replies

  • Hello Florian Hamon and thank you for your inquiry.  I have reproduced your situation.  Thank you for the pictures and details.  I also tried something else.  I published and ran in production, and it succeeded, even though the preview didn't work.  Running in debug also succeeded.

    Given the text of the error saying "System.String", and that it worked when run, I suspect that this has to do with the ability to override the default parameter.  Without running, the alternate value is unresolved.

    The important part, is that even though the preview data feature is buggy in this case, your pipeline will still run.


    Friday, May 17, 2019 10:03 PM
    Moderator
  • Thank you Martin,

    OK got it, thank you for your investigations. I'll try your way later in the week.

    Is that issue logged somewhere so it can be fixed ?

    Monday, May 20, 2019 12:21 PM
  • OK, working on my side on Debug mode, but still not in preview mode.
    Tuesday, May 21, 2019 12:37 PM
  • I'm pretty sure it is a bug.  I am alerting the product group.
    Tuesday, May 21, 2019 5:08 PM
    Moderator