none
Edit Security Group RRS feed

  • Question

  • We have a issue while Editing specific Project Server security groups.

    Project Server 2016 and October 2019 Updates installed.

    Below configuration are set:

    1. Configured sync with AD groups with Project Server security groups (done on three AD groups with three Project server groups).
    2. Configured sync with three AD groups (same AD groups) to be synced as resource pool.

    after doing this configuration suddenly, we can not edit the project server groups, and we see the below behavior.

    1. We can edit any security group that are not Synced.
    2. We can create new security groups.
    3. Slowness in loading the edit page
    4. Edit group page loads but the page missing attributes like "Group Name" & "Active Directory Group" (comes blank i mean), and the following are noticed:
    • Group GUID in the URL is correct.
    • We can not do any changes in the page.
    • We can not save, even after adding the group name manually.
    • We found the below error inside the browser (inspect mode)

    Uncaught ReferenceError: idDdlCatTemplates is not defined
        at DisableCategoryPermissionsGrid (AddModifyGroup.aspx?groupUid=52c15c90-0378-4650-ba4f-05aed6b9493a:833)
        at Workspace_OnLoad (AddModifyGroup.aspx?groupUid=52c15c90-0378-4650-ba4f-05aed6b9493a:94)
        at Body_Onload (shell.js?rev=FVoZWPj8rnjWE%2BBeA%2Fu7ag%3D%3DTAG0:2)
        at _spBodyOnLoad_PWA (shell.js?rev=FVoZWPj8rnjWE%2BBeA%2Fu7ag%3D%3DTAG0:2)
        at eval (eval at ProcessOnLoadFunctionNames (init.js?rev=iUHQ88pWz8HFvRXFm5n84A%3D%3DTAG0:1), <anonymous>:1:43)
        at ProcessOnLoadFunctionNames (init.js?rev=iUHQ88pWz8HFvRXFm5n84A%3D%3DTAG0:1)
        at ProcessDefaultOnLoad (init.js?rev=iUHQ88pWz8HFvRXFm5n84A%3D%3DTAG0:1)
        at NotifyEventAndExecuteWaitingJobs (init.js?rev=iUHQ88pWz8HFvRXFm5n84A%3D%3DTAG0:1)
        at NotifyScriptLoadedAndExecuteWaitingJobs (init.js?rev=iUHQ88pWz8HFvRXFm5n84A%3D%3DTAG0:1)
        at $_global_core (core.js?rev=%2BWMC0v9bDsr5Zvg3AwCZVg%3D%3DTAG0:1)


    Thanks & Regards Ahmed Amin

    Sunday, February 17, 2019 9:53 AM

Answers

  • Hi all,

    Just wanted to share the solution i have applied to solve the issue.

    it turned out that the real issue related to "Alternate Access Mapping".

    i made the URL what i am using the default URL in AAM and all went fine.

    Thanks for your support, hope this help someone.


    Thanks & Regards Ahmed Amin

    Saturday, April 11, 2020 10:43 PM

All replies

  • Hi,

    from your error message, it seems that something happened to at least one category (...idDdlCatTemplates is not defined..). Are you still able to edit them? If so, try to remove all affected groups from categories (write down settings before). Are you able to edit group afterwards?

    You can also try to find the causing category in ULS, so there may be no need to remove the group from all categories.

    Regards
    Barbara

    Sunday, February 17, 2019 10:08 AM
    Moderator
  • Hi Barbara,

    Thanks for your reply.

    I tried the steps you mentioned in one group (Team Members) it is inside "My Tasks" category, but it did not work.

    even this group became without category now and same issue.

    Thanks & Regards 

    Ahmed Amin


    Thanks & Regards Ahmed Amin

    Sunday, February 17, 2019 10:37 AM
  • Hi,

    what happens, if you create a simple category and assign to this group? Same issue?

    Are you able to remove your AD group from your project server group? Or can't you save it even in this case?

    Any chance to find something in ULS?

    Regards
    Barbara

    Sunday, February 17, 2019 11:01 AM
    Moderator
  • Hi,

    I found the below exceptions in ULS logs:

    Error is: GeneralUnhandledException. Details: General Unhandled Exception in _PWA.ResolveActiveDirectoryGroups_ Attributes:  System.DirectoryServices.ActiveDirectory.ActiveDirectoryServerDownException: The specified domain either does not exist or could not be contacted.    Name: "DomainName.net"   
        at System.DirectoryServices.ActiveDirectory.Locator.GetDomainControllerInfo(String computerName, String domainName, String siteName, Int64 flags) 
        at System.DirectoryServices.ActiveDirectory.Utils.GetPolicyServerName(DirectoryContext context, Boolean isForest, Boolean needPdc, String source) 
        at System.DirectoryServices.ActiveDirectory.Forest.GetTrustsHelper(String targetForestName) 
        at Microsoft.Office.Project.Server.BusinessLayer.ActiveDirectoryUtility.get_SearchDomains() 
        at Microsoft.Office.Project.Server.BusinessLayer.ActiveDirectoryUtility.TryConvertGroupAdGuidToDistinguishedName(Guid groupAdGuid) 
        at Microsoft.Office.Project.Server.BusinessLayer.ActiveDirectoryUtility.TryGetGroupInfoByGuid(Guid groupAdGuid) 
        at Microsoft.Office.Project.Server.BusinessLayer.Admin.<>c__DisplayClass10.<ResolveActiveDirectoryGroups>b__b(Guid g) 
        at System.Linq.Enumerable.WhereSelectArrayIterator`2.MoveNext() 
        at System.Linq.Buffer`1..ctor(IEnumerable`1 source) 
        at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source) 
        at Microsoft.Office.Project.Server.Wcf.Implementation.PWAImpl.<>c__DisplayClasse3.<AdminResolveActiveDirectoryGroups>b__e2() 
        at Microsoft.Office.Project.Server.BusinessObjectMethodInvocation.InvokeBusinessObjectMethod(String methodName, IEnumerable`1 actions)  . Standard Information: PSI Entry Point:  Project User: i:0#.w|domain\epmadmin Correlation Id: d2a9e1be-f622-e911-90fa-005056852fa7 PWA Site URL: http://pws/pwa SA Name: Project Services Application PSError: GeneralUnhandledException (42)

    ***********************************************************************

    [bucketHash:5875F4E5] Exception occured in method 'PWA.ResolveActiveDirectoryGroups', Exception: System.DirectoryServices.ActiveDirectory.ActiveDirectoryServerDownException: The specified domain either does not exist or could not be contacted.    Name: "DomainName.net"   
        at System.DirectoryServices.ActiveDirectory.Locator.GetDomainControllerInfo(String computerName, String domainName, String siteName, Int64 flags) 
        at System.DirectoryServices.ActiveDirectory.Utils.GetPolicyServerName(DirectoryContext context, Boolean isForest, Boolean needPdc, String source) 
        at System.DirectoryServices.ActiveDirectory.Forest.GetTrustsHelper(String targetForestName) 
        at Microsoft.Office.Project.Server.BusinessLayer.ActiveDirectoryUtility.get_SearchDomains() 
        at Microsoft.Office.Project.Server.BusinessLayer.ActiveDirectoryUtility.TryConvertGroupAdGuidToDistinguishedName(Guid groupAdGuid) 
        at Microsoft.Office.Project.Server.BusinessLayer.ActiveDirectoryUtility.TryGetGroupInfoByGuid(Guid groupAdGuid) 
        at Microsoft.Office.Project.Server.BusinessLayer.Admin.<>c__DisplayClass10.<ResolveActiveDirectoryGroups>b__b(Guid g) 
        at System.Linq.Enumerable.WhereSelectArrayIterator`2.MoveNext() 
        at System.Linq.Buffer`1..ctor(IEnumerable`1 source) 
        at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source) 
        at Microsoft.Office.Project.Server.Wcf.Implementation.PWAImpl.<>c__DisplayClasse3.<AdminResolveActiveDirectoryGroups>b__e2() 
        at Microsoft.Office.Project.Server.BusinessObjectMethodInvocation.InvokeBusinessObjectMethod(String methodName, IEnumerable`1 actions)

    Thanks & Regards Ahmed Amin

    Monday, February 18, 2019 10:33 AM
  • Hi,

    seems that Active Directory group cannot be found or name cannot be resolved. Can you please try to create a new temporary Project Server group and add the used AD group for sync? Is this possible?

    Barbara

    Monday, February 18, 2019 11:24 AM
    Moderator
  • Hi,

    i tried to create new project server security group and link it with AD group, after saving the changes i cannot see the group in the group list (this happens with any AD group).

    Furthermore i tried to create Project Server Security group without sync option, the server creates it normally without any issue. 

    Kindly note that we now patched the farm with 2019, January update thinking that this may solve the issue, but it did not.

    Thanks & Regards


    Thanks & Regards Ahmed Amin

    Wednesday, February 20, 2019 9:09 AM
  • Hi,

    I can only imagine that something happens to your AD our your project server. If no AD group can be found, there is something strange in communication between your server and AD. But I am sorry, I don't have any experience with this kind of issue.

    Regards
    Barbara

    Wednesday, February 27, 2019 6:46 PM
    Moderator
  • I haven't seen this error, but have seen a lot of things fail with different browsers.

    Which browser are you using when you got this error?

    Have you tried the following

    1) Chrome

    2) Edge

    3) IE

    Also, try right-clicking and running as administrator.

    Are you running this on desktop? or server?


    Michael Wharton, Project MVP, MBA, PMP and a Great Guy <br/> Website http://www.WhartonComputer.com <br/> Blog http://MyProjectExpert.com contains my field notes and SQL queries

    Thursday, February 28, 2019 1:43 PM
    Moderator
  • I tried all of the above browsers (IE, Chrome & Edge).

    In-addition i tried from server side & from desktop.

    Thanks & Regards


    Thanks & Regards Ahmed Amin

    Wednesday, March 6, 2019 3:09 PM
  • Do you have the site defined as a trusted site in the browser security.

    Michael Wharton, Project MVP, MBA, PMP and a Great Guy <br/> Website http://www.WhartonComputer.com <br/> Blog http://MyProjectExpert.com contains my field notes and SQL queries

    Tuesday, March 12, 2019 3:53 AM
    Moderator
  • Hi all,

    Just wanted to share the solution i have applied to solve the issue.

    it turned out that the real issue related to "Alternate Access Mapping".

    i made the URL what i am using the default URL in AAM and all went fine.

    Thanks for your support, hope this help someone.


    Thanks & Regards Ahmed Amin

    Saturday, April 11, 2020 10:43 PM