none
Cant set throughput on fixed storage capacity collection RRS feed

  • Question

  • I have an old Cosmos DB collection (it was created when Cosmos DB was called DocumentDB). The collection has a fixed storage capacity. I would like to set a provisioned throughput on the collection, but when I enter a value in the Throughput field (under "Scale & settings") and press save, the field is cleared.
    Friday, September 6, 2019 10:52 AM

Answers

  • Hi Jorgen,

    This appears to be a bug but just to be sure, can you compare both Database and Container throughput configuration? Did you enable Database throughput or only set this at the Container level?

    If this is a bug, can you open an Azure support request? If you do not have an Azure Support Plan, can you send an email to AzCommunity and include your Azure Subscription ID. Instructions will be return to you to have a support request created. Additionally, you can send an email to AskCosmosDB directly to let the product group know there is an issue. Please include both your Subscription ID and your Cosmos DB instance name and they likely will verify this and let the Azure Portal team know there is an issue. 

    Regards,

    Mike

    Monday, September 9, 2019 6:53 PM
    Moderator

All replies

  • Hi

    Could you confirm if you are looking to update Single-Partition Collection/ Partitioned Collection and is your requested setting of throughput falling under the below criteria.

    Single Partition - 400 - 10,000 RU/sec

    Partitioned Collection - 2,500 RU/sec – Unlimited

    Please confirm if your case passes the above categorization and issue still persists. Ref- Link for further details.

    Thank you


    If this post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Sunday, September 8, 2019 5:29 AM
  • My collection is a single partition (Single Partition - 400 - 10,000 RU/sec), and I still have the problem.

    Here is the text I see on the "Scale & settings" page:

    Scale
    Storage capacity 
    Fixed
    Throughput (400 - unlimited RU/s)
    Estimated spend (USD): $NaN hourly / $NaN daily (1 region, undefinedRU/s, $0.00008/RU)


    Monday, September 9, 2019 7:55 AM
  • Hi 

    Could you share the screenshot of the issue - which helps to debug.

    Thanks


    If this post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Monday, September 9, 2019 8:07 AM
  • 

    If I enter 500 in the input field and click save, I am just shown the same empty input field again.

    Monday, September 9, 2019 8:10 AM
  • Hi

    Is there any notification you can see in the top right section once you click on Save.

    And just a note: Please validate whether your subscription is active/disabled.

    Attached the reference :

    Thanks you


    If this post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.


    • Edited by nkumar230 Monday, September 9, 2019 9:13 AM
    Monday, September 9, 2019 9:05 AM
  • Hi Jorgen,

    This appears to be a bug but just to be sure, can you compare both Database and Container throughput configuration? Did you enable Database throughput or only set this at the Container level?

    If this is a bug, can you open an Azure support request? If you do not have an Azure Support Plan, can you send an email to AzCommunity and include your Azure Subscription ID. Instructions will be return to you to have a support request created. Additionally, you can send an email to AskCosmosDB directly to let the product group know there is an issue. Please include both your Subscription ID and your Cosmos DB instance name and they likely will verify this and let the Azure Portal team know there is an issue. 

    Regards,

    Mike

    Monday, September 9, 2019 6:53 PM
    Moderator
  • I have contacted Azure support and they are working on the problem.
    Wednesday, September 11, 2019 8:46 AM