Application Insights Metric Doesn't Update On Dashboard RRS feed

  • Question

  • I have created a metric in App Insights for average server response time from 6 AM to 10 PM for a specific date (10/28). I have then pinned that to a dashboard.

    I have created a duplicate metric except the date is today (10/29). We made a specific change overnight and I want to see how our response times are effected. 

    On the dashboard this second metric will only show data up to the time the metric was pinned to the dashboard. If I drill into the metric it will show the updated data, but it will not show the updated data when I return to the dashboard. 


    Tuesday, October 29, 2019 4:59 PM

All replies

  • Hello Bryan,

    Thank you for reaching out to us. 

    Have you tried refreshing the data on the dashboard? Or Have you setup "Auto Refresh" feature on the dashboard? 

    If not try doing the below steps and see if it resolves your issue. 

    • You can refresh it manually by clicking on refresh button on the dashboard page.

    • Or you can set up the Auto Refresh Time on the dashboard. 

    • The dashboard also indicates the how long ago it refreshed the last time.

    Please see the screenshot below for more reference : 

    I hope this information helps. Please feel free to reach out back to me if you have any further questions regarding this. 

    Thursday, October 31, 2019 10:05 PM
  • I have tried both manual and auto-refresh and can get neither to work.

    If I refresh in the browser then the dashboard updates..

    I wonder if the issue is due to the parameters that I have set? I have set DateTime range to custom for today (11/5 from 6 AM to 10 PM). I am just experimenting and I want to be able to see response time through the day. I update the day everyday. 

    Could this be the problem?

    Tuesday, November 5, 2019 1:24 PM
  • Hello Bryan,

    Yes you are correct, setting the Custom Datetime Range will not let the Dashboard refresh. There is an option on the Dashboard where you can remove the override functionality and it will let the dashboard refresh. 

    Please see the below screenshot and apply the same settings in your portal.

    • Click on the corner left hand side angle on the chart. 
    •  Once you click on it, it opens up the Configure Tile Settings. 
    •  If Override checkbox is checked, Ensure to Uncheck the button and it removes the override. 
    • Apply the changes. 

    Please go through this doc for more reference : Configure Tile Settings

    I hope this information helps. 


    Please Do "Mark as Answer" and Upvote on the post that helps you, so it would be beneficial for the community members.

    Wednesday, November 6, 2019 9:18 PM