locked
After publishing a package to file the data fails to load when running in VS - also it runs the application in my web-browser? RRS feed

  • Question

  • I have created a very basic Lightswitch application which gets 1 table from a server database and has 1 screen.  

    The connection string for the table is: 111.000.000.200\pocketsize,1433  {modified ip address}

    When i run this in VS - it all runs fine and loads up the data.  It also runs in some kind of VS screen, i.e. not my browser but a normal windows screen.

    If I then publish the project to a zip file for addition onto the server the next time I run the program in VS, it loads the program into a browser and the data doesn't load - no error.  The browser address is (http://localhost:56688/default.htm?IsLaunchedByVS=True&AuthenticationType=None)

    When I then deploy the package on the server, it deploys OK, but when I try to run it from a browser, I get the error:

    500 - Internal server error.

    There is a problem with the resource you are looking for, and it cannot be displayed.

    UPDATE:

    If I try and run the app on the server I have more details:

    HTTP Error 500.19 - Internal Server Error

    The requested page cannot be accessed because the related configuration data for the page is invalid.

    The detailed error states:

    Config error: The configuration section 'uri' cannot be read because it is missing a section declaration

    The specific lines in the config file are:

     117:   </system.serviceModel>
      118:   <uri>
      119:     <schemeSettings>
    

    Can anyone point me in the right direction?  I am guessing that it cannot connect to the database, but why does it work before publishing and then not after, within VS?

    thanks

    anton


    Anton


    Wednesday, July 18, 2012 2:18 AM

Answers

  • I identified the problem as the application pool settings in IIS - I changed them from default to ASP.NET v4.0 and now atleast I am no longer getting this problem.

    Anton

    Wednesday, July 18, 2012 6:11 AM

All replies

  • I identified the problem as the application pool settings in IIS - I changed them from default to ASP.NET v4.0 and now atleast I am no longer getting this problem.

    Anton

    Wednesday, July 18, 2012 6:11 AM
  • I have the same problem, but is not solved with setting the APP pool to .NET 4 :(.. I have alredy re-run the aspnet_regiis.exe -i.. and nothig.. anybody knows another solution for this?

    I have a Windows 2008 x64 

    .NET Fx x64 and x86 installed.


    SebaXOR


    • Edited by sebaxor Tuesday, August 14, 2012 5:57 AM details
    Tuesday, August 14, 2012 4:28 AM