none
Container stuck with no status and no events RRS feed

  • Question

  • I am using azure container instance for my services, but after some days of working the containers getting stuck and azure can not find them (return 404). After the problem happen the service still has a public IP but nothing else. All metrics show none usage and in the event tab there is an error that say "no events in the last hours". I can not even connect to the container because it is say that the container does not exist. The containers status contain nothing (not stopped, just dots like there is not value) and I can not start the containers but can stop them (witch is wired because azure complain that the does not exist). After I stop the containers all the data (status and events) show the values of the last manual stop.

    I have tried to run the docker in a regular server with out any problems. I also deny resources problem by monitor the resource usage.

    Tuesday, July 30, 2019 10:38 AM

Answers

  • Hi and sorry for the late answer.

    After trying the previous suggestion I added more logging and monitoring to the application.
    that reveal that any time that happen the container is using all the disk space.

    It was a bug in the program with very specific condition that cause the file not to be deleted so after the bug has been fixed the problem solved.

    Thank you anyway.

    Monday, September 16, 2019 2:50 PM

All replies

  • Hi Amit,

    I have seen the similar question opened by you on stack overflow https://stackoverflow.com/questions/57190084/container-stuck-with-no-status-and-no-events

    You have confirmed that redeploying didn't work for you in the stack thread.

    You can also go to the "Activity log" and check if there are any activities related to that.

    Also if possible share the image which you are using. So that i can deploy a copy in my subscription and check.

    Other than that i dont have other options to troubleshoot. 

    This issue needs live troubleshooting. If there are no helpful information in the activity log, Then send your subscription id to AzCommunity@microsoft.com this email id.

    I can enable a one time free support ticket for you. Later you can post the resolution here for the benefit of the community.

    Tuesday, July 30, 2019 12:15 PM
    Moderator
  • Is there an update on this issue? Did you get a chance to try the steps recommended above, please let us know.
    Thursday, August 1, 2019 10:52 PM
    Moderator
  • Hello,

    Any update on the issue?

    Just checking in if you got a chance to check the previous response.

    If your issue is resolved with the provided suggestion, do click “Mark as Answer” and "Up-Vote" on the post that helped you, so that other forum members can benefit from it.

    If you need any further help do let us know.

    Thanks
    Tuesday, August 6, 2019 10:54 AM
    Moderator
  • Hi and sorry for the late answer.

    After trying the previous suggestion I added more logging and monitoring to the application.
    that reveal that any time that happen the container is using all the disk space.

    It was a bug in the program with very specific condition that cause the file not to be deleted so after the bug has been fixed the problem solved.

    Thank you anyway.

    Monday, September 16, 2019 2:50 PM
  • Thanks for sharing the update.
    Monday, September 16, 2019 5:26 PM
    Moderator