Unable to upload application manifest file RRS feed

  • Question

  • I am trying to use AD OAuth2 client credential grant to authorize my app against O365 Sharepoint api. I created my app on corporate Azure AD, downloaded the manifest file, updated it but I have been unable to update the file. It returns the below error message:

    ParameterValidationException=Invalid parameters provided; BadRequestException=Existing credential with KeyId '<KeyId-here>' must be sent back with null value.;

    When I re-download the manifest file all attributes within the "keyCredentials" is updated correctly but not the value (certificate base 64 value), the value is always "null". Any idea why it is preventing me from updating the base64 value? Thanks.


    Going Against All Odds

    Tuesday, December 15, 2015 11:40 AM

All replies

  • Hello,


    We are researching on the query and would get back to you soon on this. I apologize for the inconvenience and appreciate your time and patience in this matter.


    Best Regards,

    Kamalakar K

    Tuesday, December 15, 2015 7:16 PM
  • Hello

    I also experience the same problem. The original manifest was downloaded and stored locally. Then a copy was made, where the certificate details in "keyCredentials" was entered. This modified file was uploaded and everything worked fine.

    Suddenly, without any manual/human actions (to my knowledge), the application that use this Azure-App stopped working reporting back "Unauthorized" when trying to get calendar details. I logged in to the Azure portal and dowloaded the manifest. The "keyCredentials" were present, but it had "null" as value on the "value" property.

    I tried to re-upload the modified manifest again, but now, it fails with the above mentioned error.

     - Mats @ Cimetic

    Wednesday, January 6, 2016 1:31 PM
  • Hello,

    I have the same problem, am not able to upload a modified manifest of the azure AD app with a value. error message is the same. Is there a workaround or solution known already?



    Wednesday, January 20, 2016 8:24 PM
  • I think I posted a message too soon, all of a sudden I saw an extra Azure AD app with a Webapp-<mywebapppname> name and the same settings as my self created AAD app. After modifying this apps manifest (which only worked once, second time same error) and changing the clientid and clientsecret in my webapp everything started to work!!!

    But where did that generated? AAD app came from?

    Wednesday, January 20, 2016 8:56 PM
  • Hi,
    I am having the same problem. Is there any solution to the problem yet?

    Sunday, January 24, 2016 10:53 AM
  • Hello,


    We are pleased to answer the query. With regards to your query, Have you tried deleting and adding the new credential?We would appreciate if you can confirm this will help us to answer your query better.

    Best Regards,

    Kamalakar K

    Monday, January 25, 2016 4:36 PM
  • Same problem here! Any update will be much appreciated.
    Friday, August 19, 2016 3:41 PM
  • Deleting and re-adding the credential worked for me, I think. I downloaded the manifest, changed the KeyCredentials value to just

    "keyCredentials": [],

    then uploaded it again. Then I downloaded it, saw that the KeyCredentials was indeed empty, replaced it with the proper content:

    "keyCredentials": [
          "customKeyIdentifier": "<$base64CertHash>",
          "keyId": "<$KeyId>",
          "type": "AsymmetricX509Cert",
          "usage": "Verify",

    This time when I uploaded it, it uploaded without error. Note that downloading it after that has all the above information but Null for the value.  I assume that's done for security, rather than actually indicating that the value is missing.

    Associate Principal Consultant, Magenic | MCITP SP2010, MCPD SP2010, MCTS MOSS & WSS Config, MCTS WSS Dev, MCSE, MCDBA, MCAD, CAPM | Webmaster, Chicago SharePoint User Group - www.cspug.org | INETA Community Champion, 2010-2012

    Thursday, September 1, 2016 6:59 PM
  • Same Issue and unable to Save manifest even after many iterations of all above suggestions
    Wednesday, May 24, 2017 11:32 AM