none
No access to Notebook VM as a creating user RRS feed

  • Question

  • I'm trying to run a Jupyter Notebook on Azure for some ML code I have.

    I followed this guide "Quickstart: Use a cloud-based notebook server to get started with Azure Machine Learning"

    When I reach the section "Launch Jupyter web interface", I do as instructed and get the following error window when clicking the Jupyter icon: 

    " User [my email] does not have access to Notebook VM [name of the VM] .

    Only the creating user has access to a notebook VM. Please create your own VM to access notebooks in your workspace "

    This is strange given I am the creating user so I don't know what to do here and I couldn't find any post on the internet related to this problem.




    Tuesday, May 14, 2019 10:17 PM

All replies

  • Hello Gabriel,

    Is your notebook-vm status in running state after you create it? I would request you to create a new vm and check again only after its status goes to running state.

    -Rohit

    Wednesday, May 15, 2019 3:52 PM
    Moderator
  • Hello Rohit,

    Yes the notebook-vm status is always in running state when I try to use it, the Jupyter icon actually only appears when it is in running state. I've tried 5-6 times creating new notebook-vm and new 'Machine Learning service workspace' and I always get the same error window.

    One thing that I do notice is that my email address is modified in the Azure portal on the top right hand corner, there are some capital letters when my real email address is all lower case so if this procedure is case sensitive then it could be causing the issue, but I'm speculating here I have no idea.

    Gabriel


    Wednesday, May 15, 2019 7:36 PM
  • Hello Gabriel,

    I have the same problem.

    I checked my access level in the notebook virtual machine and made sure I am the owner.
    So I think that this case is similar to the error of the new functionality and hope that the support will be fixed in the near future.

    Artem.

    Wednesday, May 22, 2019 5:29 PM
  • Hello Artem/Gabriel,

    Could you please let us know if you see the issue when you try to open the notebook from a new browser window or a window in incognito mode?

    -Rohit

    Wednesday, May 22, 2019 6:09 PM
    Moderator
  • Same problem here, I don't know how to create a VM and share the jupyter environment with other people

    http://pablocastilla.wordpress.com/

    Thursday, May 23, 2019 1:49 PM
  • Same here.

    I created a VM in Notebooks MV and after clicking in Jupyter icon I got the following message,

    User X@X.com does not have access to Notebook VM XX. Only the creating user has access to a notebook VM. Please create your own VM to access notebooks in your workspace.

    What can I do? Come back to Data Science VM?


    Wednesday, May 29, 2019 7:53 PM
  • Having the same issue - cannot access Notebook VM that I myself created.  Asks me to sign in - and on doing so, says invalid user id / pwd.
    Friday, June 21, 2019 8:59 AM
  • Same here. Any updates/solutions @Microsoft...
    Monday, September 30, 2019 11:36 PM
  • I am facing the same issue. 

    When I click on Jupyterlab for a running VM instance I am directed to login page, I enter my credentials then I get this:

    User live.com#xxxxx@hotmail.com does not have access to Notebook VM predict1.

    Either the notebook VM is not enabled for sharing, and it was not created by this user, or this user does not have Contributor access to the workspace containing the notebook VM.

    @Microsoft 


    Tuesday, October 1, 2019 3:26 PM
  • Hi,

    I have exactly the same problem.

    I have tried to add myself as both subscriber and owner to the workspace but to no success.

    I have also tried out the preview portal but I run into the same problem there. 

    Any information would be highly apppreciated!

    Nakah

    Tuesday, October 1, 2019 5:36 PM
  • I also tried the preview portal and got same problem. 
    Tuesday, October 1, 2019 7:39 PM
  • Hello Team,

    We have escalated the issue internally to our product team. We shall provide an update as soon as possible.

    -Rohit

    Wednesday, October 2, 2019 4:07 AM
    Moderator
  • Hi,

    Any updates on when this can be resolved? Is it within days, weeks or months?

    We think this has great potential but it is not so useful as of now since we cannot access the notebook.

    Any more information or potential work arounds would be highly appreciated.

    Best regards

    Nakah

    Thursday, October 3, 2019 10:36 AM
  • Hello,

    Could you please logout and login and check if you are still facing an issue? You can also try to create a new notebook and check if it works. There is a recent update that is pushed by our team to mitigate the issue.

    If there are further issues it may be required to check this at each subscription and workspace level. 

    -Rohit

    Thursday, October 3, 2019 11:34 AM
    Moderator
  • Hi,

    It seems the recent update solved the problem at least for me.

    I re-created a new machine learning service workspace and notebook and now it works!

    Thank you so much!

    Best regards

    Nakah

    Friday, October 4, 2019 7:18 AM
  • Hi,

    I can  see the issue is resolved. 

    Many thanks,

    Riad

    Friday, October 4, 2019 2:21 PM
  • The issue is returned. I am getting this error when I try to open Jupyter notebook from portal. 

    You can't sign in here with a personal account. Use your work or school account instead.

    Sunday, October 6, 2019 12:05 PM
  • I'm seeing the same issue as the original poster, unfortunately. With a VM I've spun up in an ML workspace I created, I get:

    > User [email-address] does not have access to Notebook VM [vm name].

    > Either the notebook VM is not enabled for sharing, and it was not created by this user, or this user does not have Contributor access to the workspace containing the notebook VM.

    > Click here to sign out and sign in again with a different account.

    It could have something to do with the fact that email-address doesn't match my Azure account name (though email-address *is* my Microsoft login username), but I can't say for sure. Any help would be appreciated.

    Friday, November 22, 2019 9:04 PM