none
ASDK 1904 deploy failure RRS feed

  • Question

  • I'm trying to deploy ASDK 1904 on a R640 PE. All prerequisites met and asdk readiness checker passes all validation. The deployment is disconnected and we're using ADFS for identity. I'm looking to see if anyone else has seen this and was able to resolve issue. Below is the section of the ASDK deployment log that pops the error...

    2019-05-07 19:41:15 Warning  Task: Invocation of interface 'Configure' of role 'Cloud\Infrastructure\POC' failed:

     

    Type 'Configure' of Role 'POC' raised an exception:

     

    A command that prompts the user failed because the host program or the command type does not support user interaction. The host was attempting to request confirmation with the following message: Do you want to restart the computer to complete this operation now?

    at Update-WindowsDismFeature, C:\CloudDeployment\Roles\Common\RoleHelpers.psm1: line 5603

    Thanks in Advance!

    Mike

    Wednesday, May 8, 2019 3:14 PM

Answers

All replies

  • Did this fail before or after you log into the VHDX? Also, try rebooting and rerunning the installation with the -rerun parameter. 

    I am currently installing 1904 on a repro machine, I will update you if I get the same error. 

    Wednesday, May 8, 2019 9:09 PM
    Moderator
  • After logging into the VHDX. Found the issue and had to add -NoRestart to line 5603 of the roleshelper.psm1. so the server wasn't trying to reboot. Deployment then finished successfully.

    Thanks

    Thursday, May 9, 2019 4:40 PM
  • Before finding that out tried the -rerun multiple times
    Thursday, May 9, 2019 4:41 PM