locked
Cannot connect to PoA Ethereum Web Socket Endpoint RRS feed

  • Question

  • I have tried attaching from both a webJS application and OpenZeppelin's CLI

    I have tried attaching to both my node and someone else's (in the same consortium)

    There are no issues connecting to the http endpoint -- but we need the web socket endpoint in order to get events.

    Is anyone succeeding in using their web socket endpoint?  If so, could I get a code sample?  (Not that I'm that it will work, but, if not, it will be a third example and one known to work on Azure PoA Ethereum).

    Thanks in advance!

    Mark

    Wednesday, April 29, 2020 3:03 PM

All replies

  • Hello Mark,

    Apologize for the late response.

    As documented here: Deploy Ethereum proof-of-authority consortium solution template on Azure

    "Ethereum Proof-of-Authority now supports web-sockets. Check your deployment output to locate the web-socket URL and port."

    Have you looked at the deployment output and were able to locate the web-socket URL and port? With that you weren't still able to connect?

    Thanks.

    Friday, May 8, 2020 7:55 AM
  • Yes, it was easy to find what the web-socket URL and port are supposed to be.

    No, we were not able to connect.
    Monday, May 11, 2020 9:46 PM
  • So . . . .  I note that the error message when attempting to connect has changed. 

    Now it says that we must connect with web sockets which is precisely what we are attempting to do.

    Could we please have the code that allows you to connect to your web sockets endpoint?

    That should be more than enough for us to fix our problem.

    Monday, May 18, 2020 9:49 PM
  • Please note that we are also having problems getting outside Besu nodes to connect.

    We have been working with the Besu folk and are having no problems connecting to non-Azure Besu nodes.

    We seem to have narrowed the problem down to the tcp connection.

    -----------------------------------------------------------------------------------------------------------

    nc -vu ethxxxxxxxxxxx.eastus2.cloudapp.azure.com 30303

    Connection to etht5zt7j-dns-reg1.eastus2.cloudapp.azure.com 30303 port [udp/*] succeeded!

    nc -vt ethxxxxxxxxxxx.eastus2.cloudapp.azure.com 30303

    nc: connect to ethxxxxxxxxxxx.eastus2.cloudapp.azure.com port 30303 (tcp) failed: Connection timed out

    ------------------------------------------------------------------------------
    Once again, could we get our hands on a working process/procedure? If we can't do this with the assistance of the Besu team, I'm sure that no one else can unless they haveaccess to some knowledge we haven't been able to find.

    Monday, May 18, 2020 9:54 PM
  • The Besu folks have confirmed that it is the lack of TCP on port 30303 that is preventing other Besu installations from linking.

    https://besu.hyperledger.org/en/stable/HowTo/Find-and-Connect/Configuring-Ports/#p2p-networking

    Which ports is the Azure Besu using?

    Tuesday, May 19, 2020 8:54 PM
  • Hello Mark

    In order to subscribe to events you can use parity pubsub
    Currently websocket connections to parity nodes is restricted to parity pubsub module , and attaching to geth is not allowed.  Please follow this link- 

    You can use the above to get details of rpc calls.

    Thanks


    Microsoft Azure Blockchain Team

    Tuesday, May 26, 2020 9:18 AM
  • Hello MWaser Mark Waser (Digital Wisdom)

    Have you had a chance to see the above response? Can you please check and update if that helps and/or if you have any further questions.

    Friday, May 29, 2020 11:29 AM