Failed to initialize Windows Azure storage emulator


  • On my Windows 7 64bit system I have IIS 7,  and VS2010 Ultimate running with all of the Azure and .Net SDKs and toolkits. I can build the Default Coud Service ASP.Net Web Role Project with a serice to retreive data from an azure sql. I created a silverlight client that calls this WCF in the web role, but when I hit F5, I get the following Error:

    Windows Azure Tools: Failed to initialize Windows Azure storage emulator. Unable to start Development Storage. Failed to start Development Storage: the SQL Server instance ‘localhost\SQLExpress’ could not be found. Please configure the SQL Server instance for Development Storage using the ‘DSInit’ utility in the Windows Azure SDK.

    I noticed in the web.config the folowing


    <add name="ApplicationServices" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|\aspnetdb.mdf;User Instance=true"

    providerName="System.Data.SqlClient" />


    I changed it to connect to the same db but on my remote sql (I dont have sqlepresss on my dev machine), tried again but getting the same error

    Thursday, December 30, 2010 11:17 AM


All replies

  • Please refer to my response to your other posting of this question. I'm 99% certain that you will need to have SQL Express installed locally. This is a free download:
    • Marked as answer by Mog Liang Thursday, January 06, 2011 9:26 AM
    Thursday, December 30, 2010 1:56 PM
  • I am facing a similar kind of issue but the error message reads as,

    "Windows Azure Tools: Failed to initialize Windows Azure storage emulator. The type initializer for 'Microsoft.ServiceHosting.DevelopmentStorage.Utilities.DevelopmentStorageConfigCache' threw an exception. Object reference not set to an instance of an object."

    This happened when i debugged the HomeController.cs file after inserting a trace statement as, "Trace.WriteLine(Request.Url.AbsolutePath);". Strange but i have already installed SqlExpress.

    Tuesday, March 27, 2012 10:16 AM
  • MariaTechie, i getting exactly this error message too.
    Monday, May 14, 2012 7:50 PM
  • Please keep in mind that thread is nearly 2 years old. :) If you do have SQL Express installed, it may be that the storage emulator was not able reach/create the necessary database. you can verify this by opening up SQL Management studio and looking for a database that is labelled starting "DevelopmentStorageDb<adatelikenumber>".

    If that's not there, you can try using the DSINIT command to get development storage properly initiated. I recently had an issue with getting this to work properly and had to complete uninstall and re-install SQL Express before it was resolved.

    Tuesday, May 15, 2012 3:13 PM