Unable to find the requested .Net Framework Data Provider RRS feed

  • Question


    Hi, I am trying to gain access to a local Access database.   I tried using "Add a new datasource" which activates the Data Source configuration Wizard.  I select New connection,


    Select Microsoft Access Database File (.Net Framework Data Provider for OLE DB)

    Hit Continue

    Browse to my MDB file.

    When I select "Test Connection"  I get a Test connection succeeded message

    When I OK out of the Add Connection Box

     I get then following message:


    Unable to find the requested .Net Framework Data Provider.  It may not be installed.


    My question is.. what is it, where is it and how do I get it?










    Wednesday, October 10, 2007 5:57 PM

All replies

  • Hey redliontrader3,


    We had an issue regarding adding a new data connection previously. Could you tell me which version of VS 2008 you are using?



    Saaid Khan


    Thursday, October 11, 2007 6:14 PM
  • I'm having the same problem, and I'm using Microsoft Visual Studio 2008 Version 9.0.20706.1 Beta 2, with the Microsoft .NET Framework Version 3.5.

    Help me.  Smile  My test connection is turning out okay, but then I get that freaky response above. I'm trying to use MySQL and have Connector installed.
    Saturday, November 17, 2007 11:50 PM
  • I'm having exactly the same problem. Is this some kind of a bug because even if I don't put anything under server, the test still reports success. I'm using the trial version of the VS 2008 Team Suite System.

    Friday, November 23, 2007 2:24 PM
  • so is this a resolved issue?  I am having the same problem, funny thing is that it worked fine on my vista machine, but downloaded and installed vb express 2008 onto my xp machine and it has the problem described above, I am still looking for the solution, but found it odd so many people post the same problem on the same thread and no answer.

    Thanks in advance
    Tuesday, June 30, 2009 9:38 AM
  • Same issue here with Vista 64 bit enterprise.  I have installed the Oracle 11g ODAC with Oracle Developer Tools for Visual Studio.  VS appears to know about it as now a third data provider shows up under Oracle.  If I select the "Oracle Data Provider for .NET", it finds my TNS names entry and successfully tests the connection.  When I click on the OK button, I get the "Unable to find the requested .Net Framework Data Provider. It may not be installed" error dialog.


    After verifying that the assembly was in C:\Windows\assembly, I checked the machine.config files

    Be sure to make a backup copy of the machine.config file before doing any editing !!!

    The machine.config file in C:\Windows\Microsoft.NET\Framework64\v2.0.50727\CONFIG had an entry for the v2.111.6.2 assembly but not v2.111.6.20.   Adding an entry DID NOT solve the problem.

    The machine.config file in C:\Windows\Microsoft.NET\Framework\v2.0.50727\CONFIG did not have an entry at all for the new assembly.  I added an entry (see below) and that solved the problem.

    Add the following entry under

    <add name="Oracle Data Provider for .NET" invariant="Oracle.DataAccess.Client" description="Oracle Data Provider for .NET" type="Oracle.DataAccess.Client.OracleClientFactory, Oracle.DataAccess, Version=, Culture=neutral, PublicKeyToken=89b483f429c47342" />

    Nicolaas Deal
    Tuesday, July 7, 2009 6:10 PM
  • Same exact problem here. Windows 7 Pro 64bit, VS 2008 Pro, trying to connect using the MySQL .Net driver 6.22, which works fine elsewhere. Most definitely a problem with VS 2008.  Anyone awake in Microsof's dream land?
    Saturday, December 26, 2009 8:16 PM