locked
Deep Zoom Composer fails to export RRS feed

  • Question

  • Hi, I'm a neophyte to Deep Zoom and SilverLight.  Maybe someone else has also had this problem.

    I have a collection of files, all 640 by 480, and all are tiles of the same image at different resolutions.  I want to export them to a Visual Studio C# solution.  It's worked for two tilings:

    • 7 tiles by 7 tiles (4480 by 3360 pixels)
    • 14 tiles by 14 tiles (8960 by 6720 pixels)

    By "it worked", I mean that I exported from DZC as png, and the VS2010 solution opened the files and I was able to make the software zoom and pan for the above two cases.  So I don't think I'm doing anything really wrong.

    When I try to export 28 tiles by 28 tiles (17920 by 13440 pixels) DZC stops exporting with not all the image files created (I think only about one third of them).  In this case I also don't get the screen asking if I want to preview in a browser.

    If this works I will want to do 56 by 56 tiles (35840 by 26880 pixels).  Is this asking too much?

    Does anyone know whether DZC has a limitation, or how I would work around this problem?  Has anyone had a similar problem and fixed it?

    Thanks in advance.



    • Edited by larry_maler Thursday, January 5, 2012 10:10 PM
    Thursday, January 5, 2012 8:36 PM

All replies

  • I have some more information on the above.  I rebooted my computer (which has 2GB of memory) and tried to export the 28x28 tile image again.

    This time it got a little farther, but then Deep Zoom Composer crashed.  I tried to debug with VS2010, which has no code, of course, but it tells me:

    Call stack location:

       PresentationCore.dll!System.Windows.Media.MediaContext.NotifyPartitionIsZombie(int failureCode) + 0xa1 bytes

    Anyone who knows what's up, please answer.  Do you think I need more memory?

    Here's the disassembly:

    00000000 push ebp

    00000001 mov ebp,esp

    00000003 sub esp,0Ch

    00000006 cmp edx,8007000Eh

    0000000c je 00000018

    0000000e cmp edx,8876017Ch

    00000014 je 00000035

    00000016 jmp 0000006B

    00000018 mov ecx,dword ptr ds:[54627A88h]

    0000001e call FFA76EF0

    00000023 mov dword ptr [ebp-4],eax

    00000026 mov ecx,eax

    00000028 call FFA73A80

    0000002d mov ecx,dword ptr [ebp-4]

    00000030 call FFA76FC8

    00000035 mov ecx,dword ptr ds:[54627A88h]

    0000003b call FFA76EF0

    00000040 mov dword ptr [ebp-8],eax

    00000043 mov edx,545E1000h

    00000048 mov ecx,70010A93h

    0000004d call FFA76FC0

    00000052 mov ecx,eax

    00000054 call FFA86D08

    00000059 mov edx,eax

    0000005b mov ecx,dword ptr [ebp-8]

    0000005e call FFA744F8

    00000063 mov ecx,dword ptr [ebp-8]

    00000066 call FFA76FC8

    0000006b mov ecx,dword ptr ds:[54627994h]

    00000071 call FFA76EF0

    00000076 mov dword ptr [ebp-0Ch],eax

    00000079 mov edx,545E1000h

    0000007e mov ecx,70010ACFh

    00000083 call FFA76FC0

    00000088 mov ecx,eax

    0000008a call FFA86D08

    0000008f mov edx,eax

    00000091 mov ecx,dword ptr [ebp-0Ch]

    00000094 call FFA72EC0

    00000099 mov ecx,dword ptr [ebp-0Ch]

    0000009c call FFA76FC8

    000000a1 int 3


    Thanks, Larry
    • Edited by larry_maler Thursday, January 5, 2012 10:09 PM
    Thursday, January 5, 2012 9:48 PM