none
InvalidResourceNamespace: The resource namespace 'Microsoft.Gallery.Admin' is invalid RRS feed

  • Question

  • Hi I'm trying to upload the default 2016 server VM into the Azure Stack Marketplace. But keep getting this error. Can you please shed some light on what is exactly going wrong? And my Azure Stack uses ADFS but still has internet access.

    PS C:\AzureStack-Tools-master> New-AzsServer2016VMImage `
    >>   -ISOPath $ISOPath
    VERBOSE: Checking ISO path for a valid ISO.
    VERBOSE: VM Image with publisher "", offer "", sku "2016-Datacenter", version "Full" already is present.
    VERBOSE: VM Image with publisher "MicrosoftWindowsServer", offer "WindowsServer", sku "2016-Datacenter", version
    "1.0.0" already is present.
    addvmimagestorageaccount
    addvmimagestorageaccount
    VERBOSE: Downloading Azure Stack Marketplace Item Generator Attempt 1

    Confirm
    Are you sure to overwrite
    'https://addvmimagestorageaccount.blob.local.azurestack.external/addvmimagecontainer/MicrosoftWindowsServer.WindowsServ
    er2016-Datacenter.1.0.0.azpkg'?
    [Y] Yes  [A] Yes to All  [N] No  [L] No to All  [S] Suspend  [?] Help (default is "Y"): Y
    New-AzsServer2016VMImage : InvalidResourceNamespace: The resource namespace 'Microsoft.Gallery.Admin' is invalid.
    At line:1 char:1
    + New-AzsServer2016VMImage `
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Write-Error], CloudException
        + FullyQualifiedErrorId : Hyak.Common.CloudException,New-AzsServer2016VMImage

    PS C:\AzureStack-Tools-master>

    Wednesday, November 15, 2017 12:40 PM

Answers

  • Hi Gary

    The issue was that in Subscription > Resource provides, Microsoft.gallery.admin was not listed as a resource provider. So a redeployment did the trick.

    Thanks 

    • Marked as answer by Global 101 Wednesday, November 29, 2017 5:21 AM
    Wednesday, November 29, 2017 4:43 AM

All replies

  • Hello,

    A couple of Questions:

    What user are logged into as when attempting to add the default image?

     

    What version of the ASDK are you running? It should be 2017.1020.1

    To check run:

     

    Get-Content "C:\CloudDeployment\Configuration\Version\version.xml"

     

    What version of AzureRM and Azure PowerShell are you running? It should be 1.2.11

    To check run:

     

    Get-Module -name Azure*

     

     

    Also – There is also an error indicating that the default image already exist.  

    Can you check your resource group and check if it already exist?

     

    Let us know how it goes.

     

    We apologize for any inconvenience and appreciate your time and interest in Azure Stack.

    If you continue experience any issues with ASDK release, feel free to contact us.

         

     Thanks


    Gary Gallanes

    Thursday, November 16, 2017 12:36 AM
    Moderator
  • Hi, thank you so much for your prompt response.

    I'm using the default AzureStack\AzureStackAdmin user.

    The version of ASDK I'm using is <Version>1.0.171020.1</Version>

    The PowerShell and other versions:

    ModuleType Version    Name
    ---------- -------    ----
    Script     1.0.5.4    Azure.Storage
    Script     1.2.11     AzureRM
    Script     0.11.1     AzureRM.AzureStackAdmin
    Script     0.10.9     AzureRM.AzureStackStorage
    Script     0.3.0      AzureRM.BootStrapper
    Script     1.2.3.4    AzureRM.Compute
    Script     3.4.1      AzureRM.Dns
    Script     3.4.1      AzureRM.KeyVault
    Script     1.0.5.4    AzureRM.Network
    Script     3.4.1      AzureRM.profile
    Script     4.4.1      AzureRM.Resources
    Script     1.0.5.4    AzureRM.Storage
    Script     3.4.1      AzureRM.Tags
    Script     3.4.1      AzureRM.UsageAggregates
    Script     1.2.11     AzureStack

    I did check the resource group and everything, the image is not there. Even the offer, I cant see it listed.

    Thursday, November 16, 2017 8:19 AM
  • Hi Gary

    I am even trying to download images from Azure Cloud, again here the image download keeps failing. I keep getting an error, saying Error Fetching tenants, but I saw from the release notes that, this error can be ignore. So, I don't see the reason for the download to fail. Please help understand.

    Thanks


    • Edited by Global 101 Thursday, November 16, 2017 10:26 AM
    Thursday, November 16, 2017 8:36 AM
  • Hello,

    It looks like we now have 2 issues going on here:

     

    1) InvalidResourceNamespace Error when running the New-AzsServer2016VMImage script

    And

    2) Download Image from Azure Marketplace continues to fail

       

    We’ll need to collect some logs to determine to root cause in order to provide a fix or workaround.

     

    If you could, please email ascustfeedback@microsoft.com to get a workspace setup to upload your logs.

     

    Make sure to use a Work, Organizational or Student address when contacting ascustfeedback@microsoft.com and please include the thread URL in the subject.

     

         

    We apologize for any inconvenience and appreciate your time and interest in Azure Stack.

    If you continue experience any issues with the ASDK release, feel free to contact us.

           

     Thanks

     


    Gary Gallanes


    Thursday, November 16, 2017 6:40 PM
    Moderator
  • Hi Gary

    The issue was that in Subscription > Resource provides, Microsoft.gallery.admin was not listed as a resource provider. So a redeployment did the trick.

    Thanks 

    • Marked as answer by Global 101 Wednesday, November 29, 2017 5:21 AM
    Wednesday, November 29, 2017 4:43 AM
  • Ensure you are correctly logged in as <g class="gr_ gr_27 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar multiReplace" data-gr-id="27" id="27">a Az</g>ure Stack operator before <g class="gr_ gr_69 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar multiReplace" data-gr-id="69" id="69">your</g> try to publish your image as per

    https://docs.microsoft.com/en-us/azure-stack/operator/azure-stack-powershell-configure-admin?view=azurestackps-1.7.1.

    <g class="gr_ gr_134 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling multiReplace" data-gr-id="134" id="134">Its</g> not very clear but that error is generally thrown because your context does not have access to the necessary provider

    Sunday, May 12, 2019 1:12 AM