The following forum(s) have migrated to Microsoft Q&A (Preview): Azure App Service - Web Apps!
Visit Microsoft Q&A (Preview) to post new questions.

Learn More

 locked
WCF applications on Azure AppService fail with error "No protocol binding matches the given address. Protocol bindings are configured at the Site level in IIS or WAS configuration." RRS feed

  • General discussion

  • Your WCF application may have recently started failing with this error:

     

    "No protocol binding matches the given address 'http://someaddress/Service.svc'. Protocol bindings are configured at the Site level in IIS or WAS configuration."

     

    This is caused by a recent change in how Azure App Service infrastructure stores the site bindings in the applicationHost.config file. The change is required in order to prevent random restarts of webapp after deployment slots swap. To prevent this error add this application setting to the webapp and all its slots:

     

    WEBSITE_ADD_SITENAME_BINDINGS_IN_APPHOST_CONFIG = 0


    Apurva Joshi, This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, March 2, 2018 6:19 PM

All replies

  • Just to confirm we had this issue and AJ's solution worked brilliantly.

    I have written up some more info about our problem and solution incase it helps anyone

    http://microsoftintegration.guru/2018/03/02/no-protocol-binding-matches-given-address-error-wcf-azure-web-apps/

    Cheers

    Mike

    Friday, March 2, 2018 8:57 PM
  • An alternative way to fix this is to modify the web.config setting and set the multipleSiteBindingsEnabled to true.

    <serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" />


    http://ruslany.net/

    Friday, March 2, 2018 11:24 PM
  • After a two and a half day search and debug marathon, this fixed our problem!

    Unfortunately, we did a (re)publish of our service a few hours before this happened, so at first we were confinced it was a coding issue. :(

    Thank you AJ!
    And kudos to Mike for the nice blog post about it.

    Thursday, March 8, 2018 10:26 AM