The following forum(s) have migrated to Microsoft Q&A (Preview): Azure Virtual Machines!
Visit Microsoft Q&A (Preview) to post new questions.

Learn More

 locked
Azure VM IP reporting incorrect RRS feed

  • Question

  • Hi,

    I operate an RDS platform in Azure, I've just added a new server into the subscription and it's "mostly" fine. The new VM reports itself on the right IP (10.1.19.4) and I can connect in to it fine. I can also add it to the AD's within Azure without issue.

    Note: The VM's are all static IP's within vnets. No DHCP going on.

    Problem is this, nslookup for the new VM reports back as 10.1.18.4 which is in use by another VM already in the subscription. That other VM works fine, and I can connect into it fine. So when trying to add the new VM into the RDS collection, it fails to find the right IP and is giving me a kerberos error.

    I've tried the things I know, ipconfig /dnsflush, ipconfig /dnsregister, and I've tried scavenging stale resource records and I've checked the hosts file for anything odd (it's totally stock). No joy. There's clearly something sitting in a table/database/file somewhere, but I can't track it down.

    Any suggestions would be welcomed.
    Tuesday, December 10, 2019 11:36 PM

All replies

  • HI,

    I have couple of questions in this scenario.

    When you have converted your VM's ip to DHCp to static?

    During VM creation of after creating the VM.

    If you have changed the ip config of that nic (in portal or using CLI) from dynamic to static after machine creation,

    Then you need to restart the machine to apply the new configuration.

    Regarding the DNS, whats the suffix of your DNS suffix.  is it cloudapp.net or your companys domain.

    If its ending with cloudapp.net, Then after restarting the machine, The new Azure will update the new ip (static or dynamic) to the hostname.

    Then you will be able to query the hostname, (cloudapp.net) from other vms.

    If you are using your company domain, Then you need to update your DNS with the hostname of new ip.

    Let me know the answers for the questions. We can take it forward.

    Wednesday, December 11, 2019 12:53 PM
  • Hi,

    The IP is setup during VM creation, along with the address space & subnets - it gets set to static after the creation is complete when the NSG's get done.

    The suffice is our company domain.

    To be clear, the process we follow has worked perfectly for the previous 18 VM's, just this one appears to be throwing a spanner in the works.

    Regards,

    Wednesday, December 11, 2019 1:34 PM