locked
Registration Tool erroring out RRS feed

  • Question

  • All,

    Since today, I'm unable to connect with the Registration Tool and I get the below error. On the Infrastructure nothing changed and I confirmed it with the admin as well. Has anyone come across this before.

    Thanks

    rgn

    We are unable to confirm that 'rgn@mycompany.com' is enabled for the Azure Data Catalog.

    If you believe you have received this message in error, please contact your catalog administrator with this code: 5d2b3891-dbe7-4286-bfe7-bf710e680582

    Monday, May 11, 2020 6:09 PM

Answers

All replies

  • Hi grajee,

    Due to Azure Security requirement  like all other Azure Services, Azure Data Catalog Service disabled TLS 1.0, TLS 1.1 and moved to TLS 1.2. Please follow below documentation to update the Client Machine to add "SystemDefaultTlsVersions" = dword:00000001 and "SchUseStrongCrypto" = dword:00000001subkey values in the registry. 

    Please follow this document for steps: How to enable TLS 1.2 on clients



    After updating the registry, please restart the machine and then try login to ADC Registration tool. 


    Related MSDN Threads

    Hope this helps. 


    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Monday, May 11, 2020 7:04 PM
  • I don't have access to my laptop's registry and I will have to ask the support team to address it.

    However, I'm looking at my Home PC just to get an idea as to how the entries might look in my laptop and I don't see the above entries at all. Does this I mean these entries can be added if they don't exist?

    rgn

    Monday, May 11, 2020 10:20 PM
  • We have the same issue at my company

    the Registration Tool is not working.

    And the error is:

    We are unable to confirm that 'aa@mycompany.com' is enabled for the Azure Data Catalog.

    If you believe you have received this message in error, please contact your catalog administrator with this code: 47f90dc1c-7743-4d76-a2b3-2e728220bbb2

     in the regedit "SystemDefaultTlsVersions" = dword:00000001 and "SchUseStrongCrypto" = dword:00000001

    cannot be found.

    Please help!

    Tuesday, May 12, 2020 12:03 PM
  • Its working.

    We added the registry entries on our 64bit client.

    Use new DWORD (32-bit) value

    modify value data set to "1", base hexadecimal

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v2.0.50727]
          "SystemDefaultTlsVersions" = dword:00000001
          "SchUseStrongCrypto" = dword:00000001
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319]
          "SystemDefaultTlsVersions" = dword:00000001
          "SchUseStrongCrypto" = dword:00000001

    Now the Registration Tool is working! :)


    • Edited by HenryHari Tuesday, May 12, 2020 12:29 PM
    Tuesday, May 12, 2020 12:22 PM