none
Azure IoT Edge Quickstart Linux - can't even create a VM RRS feed

  • Question

  • I'm stuck almost at the very beginning of the process at https://docs.microsoft.com/en-us/azure/iot-edge/quickstart-linux. I can't even create a VM. Under Prerequistes -> IoT Edge Device, I executed the 'az vm image' command without any problem, but the 'az vm create' command fails with this error message in the Azure Cloud Shell:

    ray@Azure:~$ az vm create --resource-group IoTEdgeResources --name EdgeVM --image microsoft_iot_edge:iot_edge_vm_ubuntu:ubuntu_1604_edgeruntimeonly:latest --admin-username azureuser --generate-ssh-keys
    Azure Error: InvalidTemplateDeployment
    Message: The template deployment failed with error: 'The resource with id: '/subscriptions/5f82f9e0-c505-4cad-a22b-63e6db8b33e8/resourceGroups/IoTEdgeResources/providers/Microsoft.Compute/virtualMachines/EdgeVM' failed validation with message: 'The requested size for resource '/subscriptions/5f82f9e0-c505-4cad-a22b-63e6db8b33e8/resourceGroups/IoTEdgeResources/providers/Microsoft.Compute/virtualMachines/EdgeVM' is currently not available in location 'westus2' zones '' for subscription '5f82f9e0-c505-4cad-a22b-63e6db8b33e8'. Please try another size or deploy to a different location or zones. See https://aka.ms/azureskunotavailable for details.'.'.

    I'm running the 120-day free trial of Azure. I don't know how to deploy to a different location, how to specify another size, or which other size to try. I'm stuck here, and I'm nowhere near first base.

    My goal in this exercise is to deploy Azure IoT Edge on an Armv7L-based edge compute device. The Quickstart guide wants to walk me through deploying Edge on a virtual machine first. This error has to do with the VM, not with my edge hardware. This obstacle is irrelevant, and terribly frustrating.

    Tuesday, September 24, 2019 4:14 PM

All replies