none
ADODB.connection error after ugrading the windows version 7 to 10 RRS feed

  • Question

  • Hi All,

    Good afternoon:)

    We have an excel which will connect to optim archived data via ODBC using ADOBD.connection, It worked fine till now but after windows version migration it stopped working, Connection is not getting established. i am not sure what might be the issue, Can anyone please me to resolve since it is an urgent requirement.

    Thanks & Regards,

    Revathi Mylapalli.

    Thursday, November 28, 2019 11:49 AM

All replies

  • below is the code that we are using for connection

    Dim myConnectionString As String
    myConnectionString = "DRIVER={Optim Connect Driver for ODBC 3.5};qptdpname=BINDURL1;queryProcessor/noThreads=true;OneTdpMode=1;debug/logFile=ODBC_MYDSN_%p.log;BindUrl=attconnect://Aupr1ap017nabwi.aur.national.com.au:2551:fixednat/11_Eros;misc/language=enus;DefTdpName=EROS;UID=" + USERNAME + ";PWD=" + PWD + ";"
    Dim myConn As ADODB.Connection
    Dim Common_data As ADODB.Recordset
    Dim rs As ADODB.Recordset

    Set myConn = New ADODB.Connection

    'On Error Resume Next
    myConn.Open myConnectionString

    Thursday, November 28, 2019 11:50 AM
  • Hi RevathiMylapalli,
    As far as I know, the code produced on Windows 7 SP1 using ADODB cannot be run on any other version of Windows because of  the IIDs differ.
    About how to handle this issue, you can refer to Pak-Ming Cheung’s answer.
    Best Regards,
    Daniel Zhang

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, November 29, 2019 7:22 AM