locked
TFS 2017.2 - Emails alerts received multiple times for all users RRS feed

  • Question

  • Since we upgraded to TFS 2017.2 a few weeks ago, we notice that some of the notification emails that are sent are received twice.

    But not both at the same time, the 2nd, or sometimes 3rd messages comes about 15-30 minutes later.

    I have confirmed these messages were triggered by the same subscription, its not the case that a user has 2 subscriptions that are triggered. The exact same email is send again after 15-30 minutes.

    there are no hanging messages in the Tbl_MailQueue table, i have checked the _io page and shows no errors for the Email notifications. 

    How should we troubleshot this further ? i see no errors popping up anywhere. 

    The issue was gone for a week or so, but came back since a few days.

    Please let me know if you have any suggestions.

    Technical Details: Build Ran for 15.3 minutes (Default), completed at Fri 12/01/2017 01:48 PM
    
    1st email header: Received: from TFSAPPSERVER (ip) by smtphost.domain.com (ip address) with Microsoft SMTP Server id 14.3.319.2; Fri, 1 Dec 2017 07:50:34 -0600 ( 01:50 PM translated to same timezone above)
    
    2nd email header: Received: from TFSAPPSERVER (ip) by smtphost.domain.com (ip address) with Microsoft SMTP Server id 14.3.319.2; Fri, 1 Dec 2017 08:26:37 -0600 ( 02:26 PM translated to same timezone above)


    • Edited by nsijtsma Friday, December 1, 2017 3:16 PM
    Friday, December 1, 2017 2:50 PM

All replies

  • Hi nsijtsma,

    If you send a test email from TFS Administration Console, are you able to reproduce this issue?

    Please check event log in Event Viewer to see if there is any useful information. Also, you could check the list of subscriptions in tbl_EventSubscription table of each collection database to see whether you have subscribed it multiple times.

    Best regards,


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, December 4, 2017 7:26 AM
  • Hi Cece,

    I am not able to reproduce it using the test email button. The event log also shows no errors.

    As mentioned, its not a case of duplicate subscriptions. The emails are an exact match with a link in the bottom to the same subscription.

    The email is resend for some reason by TFS, perhaps it thinks it didn't complete the job ??

    It started re-occurring last week, the week before that we had no duplicates at all.

    Monday, December 4, 2017 8:07 AM