none
AxImp Error: Did not find a registered ActiveX control in RRS feed

  • Question

  • I have a MFC ActiveX Control, which I built using the debug x64 configuration.

    The Visual Studio 2019 Command Window is able to register the OCX control properly. I then in the same window ran aximp.exe, which yielded the above error message.

    "AxImp Error: Did not find a registered ActiveX control in 'C:\TempAximp\DriveOps.ocx'.

    I even added the /verbose option. Without that option and without the /nologo returns the exact same failure message.

    Adding the ActiveX control directly to the project yields:

    DriveOpsLib.dll, is there, but AxDriveOpsLib.dll is AWOL.

    I should add that tlbimp.exe is runs perfectly. I can use ildasm.exe on the file.

    This project was originally written for Visual Studio 2010. The x64 configuration imports perfectly into the project. Aximp.exe also works nicely.

    Visual Studio 2010 command prompt importing a x64 (64-bit) OCX file works fine with everything importing from the IDL file fine, x64

    I cannot use tlbimp.exe to generate the AxDriveOpsLib.dll as that yields an empty import.

    Here is the empty namespace that tlbimp.exe created in the VS2019 environment, so I really have to use aximp.exe and I want that utility to work.

    One article that I found talks about keeping bitness. I have a 64-bit OCX with various components. I did try running regsvr32.exe from the DLL directory and again from C:\Windows\System32. Both register fine and yield aximp.exe with the same error. Yes, I know of 32-bit (x86) DLLs must be called from the C:\Windows\SysWow64 folder, but that does not apply here.

    A second article talks of calling everything from the same command window and then as administrator. I did that, as you can see from earlier in this post.

    Yet a third article said that aximp.exe is not necessary and just add the OCX directly to the project. If Visual Studio 2019 would agree that there is no reason for aximp.dll, then I would wholeheartedly agree as well, but sadly that does not work and I should be able to call aximp.exe. One problem more than likely is the same as the other.

    Thoughts?
    Tuesday, October 22, 2019 3:47 PM

All replies

  • Hello,

    Thank you for posting here.

    Can you share three articles which you said. It's hard for us to restore your situation based on the existing information.

    Best Regards,

    Suarez Zhou


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, October 23, 2019 8:21 AM
  • [If you (or someone else) is a member of Stack Overflow, please uptick the question. I worked hard composing it and gather the details, especially since you are asking for the detailed information.]

    https://stackoverflow.com/questions/58494253/aximp-error-did-not-find-a-registered-activex-control-in

    Everything that you need should be there. I used to have extra screenshots, but the SO cult police forced me to take them down, sad, oh well, gone forever.

    Thoughts?


    Wednesday, October 23, 2019 7:47 PM