none
Visual Studio F# function 'quickinfo' signature display RRS feed

  • Question

  • Just checking if this problem has already been reported for Visual Studio 2019 (I am using Community Edition 16.2.5 on Windows 10).  I tried searching and didn't see anything useful but I don't really know what to search for as I have no idea what this feature could be called.

    The 'quickinfo' function signature display in the source code (commented text in a smaller red only font to the right in the image below) is misaligned and overwritten in spots.

    It doesn't disappear if you scroll it out of view. Closing the file and re-opening clears it up, at least temporarily. This is the bug part.

    Although I find this display can be quite useful, sometimes I just want to see the uncluttered code. Is there a way to turn this feature on and off?


    Sunday, September 29, 2019 4:12 PM

Answers

  • Finally located the problem.  The annotations are part of the experimental CodeLens feature which I had enabled without really understanding the feature or its impact. Disabling resolved the issue.
    • Marked as answer by Barfarkle Saturday, October 5, 2019 2:58 PM
    Saturday, October 5, 2019 2:58 PM

All replies

  • Hi Barfarkle,

    Since it is related to the Visual Studio F# function, to help you really repro this issue, I will help you move it to the F# forum. 

    Of course, if it is really a feedback, you could also report it directly:

    https://docs.microsoft.com/en-us/visualstudio/ide/how-to-report-a-problem-with-visual-studio?view=vs-2019

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, October 1, 2019 3:31 AM
  • Finally located the problem.  The annotations are part of the experimental CodeLens feature which I had enabled without really understanding the feature or its impact. Disabling resolved the issue.
    • Marked as answer by Barfarkle Saturday, October 5, 2019 2:58 PM
    Saturday, October 5, 2019 2:58 PM