locked
DRM/Content Protections :: Azure Portal RRS feed

  • Question

  • Hi

    I'm trying to test DRM/Content protection in Azure Media Services all done via the Azure Portal. I've uploaded an Asset (mp4) and have encoded it to "content Adaptive Mulitple Bitrate MP4" and then have turned on "Encrypt" before publishing the asset.

    The issue i have is that the stream is still unencrypted. I can watch the stream using Azure Media Player without requiring a license. Authorisation is set to open and I don't require authenitcation. What an I doing wrong?

    Encryption settings are PlayReady and Widevine with MPEG-DAS and the asset shows

    ENCRYPTION PlayReady and Widevine for MPEG-DASH

    I've unpublished and then published again, but still doesn't work.

    James

    Monday, May 4, 2020 12:53 PM

All replies

  • I was able to reproduce your issue Lodge. I'm following up with the media services team to see if there's something we're both doing wrong. I'll update this thread with my findings.

    EDIT:

    Make sure you published a streaming locator endpoint (screen shot below).  A progressive endpoint is for downloading the media file over HTTP.  You can learn more about the differences in this blog post.  You can use https://ampdemo.azureedge.net/ to test your video at the streaming endpoint, which is what I did.  The player failed to playback the video due to the encryption. DRM gets applied dynamically to the asset when streamed over one of the streaming protocols: MPEG-DASH, Smooth Streaming, and HLS. Now, getting token can get complicated and the easiest option is to use the Azure Media Services Explorer tool.  This blog post walks you through more details on token authentication with AES and how to utilize AMSE to retrieve/generate a token for your encrypted media file.

    Hope this helps.


    Thanks in advance, Ryan




    Tuesday, May 5, 2020 5:41 PM
  • I am publishing a stream locator, otherwise I've have no stream and wouldn't see that its unecrypted! Also I'm using the https://ampdemo.azureedge.net/ to test, that how i know the stream ins't encrypted.

    My step are this

    1. Start Streaming Endpoint 

    2. Encrypt asset DRM > ReadyPlay and Wadevine

    3. Publish Streaming Locator(Do you need both a streaming and progressive locator to make DRM work? I've tried that and still get an unencrypted stream).

    Still doesn't work. How is it your first attemped didn't work, but now it does? What were you doing wrong the first time round?
    • Edited by Lodge UK Thursday, May 7, 2020 9:47 AM
    Thursday, May 7, 2020 9:46 AM