none
Click Once Installer has stopped working RRS feed

  • Question

  • I have developed an Outlook Add-In, addin1 using Add-In Express in VS 2013 using C# on Win 10. I started developing a second one,addin2, which I was able to publish OK, creating files in the project's Publish folder. When I tried to install it by clicking on the addin2.application file I received a message that the installation had failed due to a lack of trust for ClickOnce applications. I then changed a number of things after researching the problem but then clicking on addin2<g class="gr_ gr_28 gr-alert gr_gramm gr_inline_cards gr_run_anim Style replaceWithoutSep" data-gr-id="28" id="28">.<g class="gr_ gr_21 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar only-ins replaceWithoutSep" data-gr-id="21" id="21">application</g></g> did not run the installation at all. Clicking on Setup.exe I was pointed to a log file with included the line Error: An error occurred trying to download 'http://localhost/addin2/addin2.application'. When I tried to run a previously working ClickOnce installer by clicking addin1.application. I received the same error.

    When I clicked on the entry in the programs menu for the Add-In, instead of showing the addin1 Setup screen with the option to unregister, I received the same error and the menu entry became addin1.appref-ms instead of just addin1. It appears I have somehow changed Win10 to prevent it from registering or unregistering ClickOnce add-ins.

    I have tried restarting the Win 10 computer but don't wish to do a complete reinstall of the operating system and the many programs I use. Can anyone suggest a way to reverse what I have done to stop ClickOnce from working? (I don't have any OS restore points either).

    Saturday, June 15, 2019 1:52 AM

All replies

  • Hi Simon,

    About "failed due to a lack of trust", here I found a solution maybe you can refer to.

    Unable to Install ClickOnce Application due to Security Settings (Windows 10).

    Regards,

    Kyle

    Note: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; Therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, June 17, 2019 2:24 AM
    Moderator
  • This describes a solution to a different error, but the problem of no Click Once installation seems to have disappeared. I still have a problem though - see  https://social.msdn.microsoft.com/Forums/windows/en-US/c0a08152-c461-4044-a60d-e44c557364ee/clickonce-installation-error?forum=winformssetup

    Monday, June 17, 2019 3:02 AM
  • Hi,

    Did you check ClickOnce Trust Prompt Behavior by referring to How to: Configure the ClickOnce Trust Prompt Behavior.

    Regards,

    Kyle


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, June 17, 2019 9:59 AM
    Moderator