none
Host Plan doesn't attach WebsitePanel RRS feed

  • Question

  • We try to make this with assistance API, but it is impossible and API writes this error:

    Product ID: 10408189

    attach_plan_to_user :: Access Denied

    attach_organization_to_package :: Server was unable to read request. ---> There is an error in the XML document. ---> Input string was not in a correct format.

    attach_domain_to_organization :: Server was unable to read request. ---> There is an error in the XML document. ---> Input string was not in a correct format.

    set_organization_default_domain :: Server was unable to read request. ---> There is an error in the XML document. ---> Input string was not in a correct format.

    But We can independently make it with assistance WebsitePanel.

    Guys tell me what could be the problem?




    • Edited by Eugene_Sh Friday, May 27, 2016 8:09 AM
    Friday, May 27, 2016 7:34 AM

All replies

  • Hi Eugene_Sh,

    ---> There is an error in the XML document. ---> Input string was not in a correct format.

    The error indicates an incorrect format, this can be caused by having a blank or incorrect value. For example, a field that expects an integer format is receiving a string, or a field expecting a currency format is receiving a date. Check all the fields you have mapped match the expected data types.

    Best Regards,

    Chris

    Saturday, May 28, 2016 3:00 AM
    Moderator
  • I need to know what it means attach_plan_to_user :: Access Denied ?
    Wednesday, June 1, 2016 11:08 AM
  • Hi Eugene_Sh,

    If anonymous access authentication is not allowed, or you don't have permission to access, you may receive "Access Denied".

    Best Regards,

    Chris

    Thursday, June 2, 2016 9:16 AM
    Moderator
  • the problem is that we use Serveradmin account which have full permissions, also we can assign hosting plan using GUI, but get error when use API.
    Thursday, June 2, 2016 10:05 AM