Windows Azure deployment to local emulator fails after upgrading to SDK & Tools 1.5


  • After upgrading to Azure SDK & Tools 1.5 (September 2011), deployment to local compute emulator does no longer work.

    The following dialog hangs at about 35%:

    And then Visual Studio asks to stop deployment:

    Storage and Compute emulators are started successfully.


    There are no any related errors in Windows Application Event Log. So... how to find a problem and fix it?
    Monday, September 19, 2011 5:24 AM


All replies

  • Here is how Storage and Compute emulators look like:

    Where does Azure Tooling write its error and trace log?
    Monday, September 19, 2011 5:26 AM
  • I have seen a suggestion that the compute emulator does not work when installed in a login that has a space in the name. I encountered this problem and resolved it by logging in as Administrator, and installing the SDK and running the emulator in that account.
    Monday, September 19, 2011 5:45 AM
  • There are no spaces in user name under which SDK is installed and running (just letters [a-z])
    Monday, September 19, 2011 5:48 AM

    I guess that could be because of Windows Process Activation Service not running correctly... How to fix it?


    2011-9-19T11:57:8.306, 2081, 10, Information, 201523260, Logging event CommFxClientOperationInvoked with params: Id={0} TimeAtActionInvoke={1} ClientVersion={2} ClientCapabilities={3} From={4} To={5} Action={6} `00000000-0000-0000-0000-000000000000`19.09.2011 11:57:08`<null>`<null>`COMPNAME`net.tcp://localhost/dfagent/1/host`IAgent/GetState`
    2011-9-19T11:57:8.309, 2082, 10, Error, 0, d0a5f462-8e92-433f-8e34-f9d5b1601e38`GetAgentState`System.ServiceModel.EndpointNotFoundException: The message could not be dispatched because the service at the endpoint address 'net.tcp://localhost/dfagent/1/host' is unavailable for the protocol of the address.
    Server stack trace: 
       at System.ServiceModel.Channels.ConnectionUpgradeHelper.DecodeFramingFault(ClientFramingDecoder decoder, IConnection connection, Uri via, String contentType, TimeoutHelper& timeoutHelper)
       at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.SendPreamble(IConnection connection, ArraySegment`1 preamble, TimeoutHelper& timeoutHelper)
       at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.DuplexConnectionPoolHelper.AcceptPooledConnection(IConnection connection, TimeoutHelper& timeoutHelper)
       at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout)
       at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.Channels.ServiceChannel.CallOnceManager.CallOnce(TimeSpan timeout, CallOnceManager cascade)
       at System.ServiceModel.Channels.ServiceChannel.EnsureOpened(TimeSpan timeout)
       at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
       at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
       at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)
    Exception rethrown at [0]: 
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at RD.Fabric.Controller.IAgent.GetState()
       at RD.Fabric.Controller.DevFabricAgentInterface.<>c__DisplayClass2b.<GetAgentState>b__2a(IAgent agent)
       at RD.Fabric.Controller.DevFabricAgentInterface.CallAgent(AgentCallDelegate agentCall, String operation)`
    2011-9-19T11:57:8.311, 2083, 10, Information, 0, GetAgentState fails.`


    And here is a DFAgent log:


    [2011/09/19, 12:43:49.708,  INFO, 00011216] StorageRoot: C:\Users\UserName\AppData\Local\dftmp
    [2011/09/19, 12:43:51.286,  INFO, 00011216] Using envfile:C:\Users\UserName\AppData\Local\Temp\tmpF105.tmp
    [2011/09/19, 12:43:51.362,  INFO, 00011216] DFAgent host address: net.tcp://localhost/dfagent/1/host
    [2011/09/19, 12:43:51.364,  INFO, 00011216] Setting all Sids to Built-in administrators...
    [2011/09/19, 12:43:51.365,  INFO, 00011216] Initializing Runtime Http Monitor...   
    [2011/09/19, 12:43:51.366,  INFO, 00011216] Done.
    [2011/09/19, 12:43:51.366,  INFO, 00003752] >>>>_Context_Start: {2BC5C976-5D04-46C0-B3C0-49559DC6EE6F}		Context={{ RuntimeHttpMonitor }}
    [2011/09/19, 12:43:52.663,  INFO, 00011216] There is already a listener on IP endpoint  Make sure that you are not trying to use this endpoint multiple times in your application and that there are no other applications listening on this endpoint.
    [2011/09/19, 12:43:52.663,  INFO, 00011216]    at System.ServiceModel.Channels.SocketConnectionListener.Listen()
       at System.ServiceModel.Channels.BufferedConnectionListener.Listen()
       at System.ServiceModel.Channels.ExclusiveTcpTransportManager.OnOpen()
       at System.ServiceModel.Channels.TransportManager.Open(TransportChannelListener channelListener)
       at System.ServiceModel.Channels.TransportManagerContainer.Open(SelectTransportManagersCallback selectTransportManagerCallback)
       at System.ServiceModel.Channels.ConnectionOrientedTransportChannelListener.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.TcpChannelListener`2.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.Dispatcher.ChannelDispatcher.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at Microsoft.Windows.Azure.Fabric.Cfx.Contracts.CommunicationFrameworkServiceHostBase`1.Open()
       at Microsoft.Windows.Azure.Fabric.Cfx.CommunicationFramework.CommunicationFrameworkServiceHost`1.Open()
       at Microsoft.Windows.Azure.Fabric.Cfx.CommunicationFramework.CommunicationFramework.StartService[TService](CommunicationFrameworkServiceHostBase`1 serviceHost)
       at main(Int32 argc, SByte** argv)
    [2011/09/19, 12:43:52.663,  INFO, 00011216] Host is up and running

    Monday, September 19, 2011 10:13 AM
  • I solved this problem by removing *:808 binding in IIS Manager for Default Website.
    Monday, September 19, 2011 8:34 PM
  • Thanks Konstantin! Stumbled on this post just when I was about to give up on this issue altogether.

    As an aside, any reason why this particular endpoint is being used by the dev fabric ?

    Wednesday, October 19, 2011 4:48 PM
  • I too resolved the issue by removing *:808 binding. It took my 2-3 days. There was no option of reinstalling the OS and all because we are using same machine image (everything pre-installed)through out the project ,
    Thursday, November 03, 2011 10:34 AM
  • Just check is local port 808 is free and no other programs are bind to that port at this moment.  You can use TCPView.exe from ( to check is port is used.

    In my case Team Foundation Server Integration Tools service was bind to port 808 and doesn't allow Azure computer emulator to start. Stop that service and computer emulator is working again

    Thursday, November 10, 2011 2:24 PM
  • I upgrade from 1.4 to 1.5 and I'm getting the following error message when I try to debug with the compute emulator.



    It seems like the Tools for Microsoft Visual Studio isn't in the right version but I uninstalled and double checked. Still not working. Any ideas? Thanks.

    Friday, November 11, 2011 1:23 AM