none
Azure AD B2C fails RRS feed

  • Question

  • We are using Azure AD B2C for user management for our application. It was working fine and suddenly it stopped working. It started working fine after 1 hour or so. We have checked in the app insights logs but there are not many details. This is the exception message - Exception Message:An internal error has occurred., CorrelationID:09d2d010-1ef2-4b27-bf0a-61beddf30761

    We do not have any clue as what happened and why it started working again. Appreciate your help if you can provide any details.

    Thanks,

    Srinivas

    Monday, October 21, 2019 12:00 PM

All replies

  • We are using Azure AD B2C for user management for our application. It was working fine and suddenly it stopped working. It started working fine after 1 hour or so. We have checked in the app insights logs but there are not many details. This is the exception message - Exception Message:An internal error has occurred., CorrelationID:09d2d010-1ef2-4b27-bf0a-61beddf30761

    We do not have any clue as what happened and why it started working again. Appreciate your help if you can provide any details.

    Thanks,

    Srinivas

    Monday, October 21, 2019 12:10 PM
  • Hello srinu0681

    This can occur when back-end account creation fails sometime. However , its difficult to be sure of what could have exactly been the reason as "An Internal error has occurred" is a very generic message and may be seen due to multiple factors either on the HTTP client side or due to some interruption on our backend. As we do not have much information it is difficult to pinpoint a cause. A correlation ID with timestamp would be required to troubleshoot this. However before that , could you please try checking the Audit logs on the B2C directory . The audit logs are retained for 7 days so , if the error is from today , you should be able to find some relation if you search around the same timestamp. 

    From the detail you have provided it seems that you have configured Log analytics for log collection. However , it is only recommended to use while checking custom policy functionality and the detailed logs are only available in Development mode.  As you mention that you have tried checking in log analytics, could you also check if you had enabled development mode? If not , you may not get detailed logs in this case. In case you are still unable to figure out the cause , I would suggest to send us an email along with your azure subscription Id on azcommunity[at]microsoft[dot]com and we will try to help further on this. I assume that you may have already checked some articles however , I have linked to some articles which will provide more details to understand the problem and I suggest you check the same if not already checked. 

    Hope the information provided helped. Please let us know in case of any further queries. 

    Hope this was helpful. 


    Please take a moment to "Mark as Answer" and/or "Vote as Helpful" wherever applicable. Thanks!!


    Monday, October 21, 2019 3:07 PM
    Moderator
  • srinu0681, Based on the Exception Message i.e an Internal Error, I believe this error got thrown by the application. If yes, then it might be an issue with the application that might have happened during that period.

    But if you see that error being thrown by B2C, then it would be great if you can share some more insight around the error like any error code that was thrown.

    Monday, October 21, 2019 5:21 PM
    Moderator
  • Thanks for the response ShashiShailaj_MSFT

    Yes, we are using custom policy functionality and enabled Development mode. 

    I checked in the audit logs but unfortunately I did not get any clue for the issue.


    Tuesday, October 22, 2019 7:19 AM