none
Biztalk 2016 LOB Adapter Pack Installation RRS feed

  • Question

  • Hi All,

    On our production server number of applications are already running. We are now going to integrate with SAP.

    But WCF-LOB adapters pack is not installed on PROD server. 

    Can we install it while messages are flowing. Will it effect any running applications. Please guide.

    Thanks in advance.

    Regards,

    Pooja



    Pooja Jagtap Software Engineer KPIT Cummins

    Thursday, November 7, 2019 4:36 AM

Answers

  • Usually installing and configuring a new adapter at the very least requires a restart of the Host Instance you are configuring the adapter on.  So you would be better of doing it as an outage.
    • Marked as answer by Pooja Jagtap Friday, November 15, 2019 6:44 AM
    Thursday, November 7, 2019 11:35 PM

All replies

  • Usually installing and configuring a new adapter at the very least requires a restart of the Host Instance you are configuring the adapter on.  So you would be better of doing it as an outage.
    • Marked as answer by Pooja Jagtap Friday, November 15, 2019 6:44 AM
    Thursday, November 7, 2019 11:35 PM
  • Hi Colin,

    Thanks for reply. does the installation of adapter pack will affect  existing applications deployed in BT admin console.

    Do I need to take backup of msi's and binding files of existing deployed application in Biztalk.

    Please let me know. Thanks.

    Regards,

    Pooja


    Pooja Jagtap Software Engineer KPIT Cummins

    Monday, November 11, 2019 11:04 AM
  • No, it should not impact existing applications.

    But always try it out in a test environment first, and take a snapshot/backup of the servers and database just in case you do have to roll it back.

    Monday, November 11, 2019 7:30 PM